Alert Powerplay Offline for P10

Does anyone can tell me what happen on P10…

I got a mail that Unit ID 117525 Alert Powerplay Offline found this afternoon then I told a look on my P10 and found “globe” symbol turned on on Home Screen.

I tried to check on web browser by using Firefox, it can connect to P10 after typing IP address “192.168.1.14” on Firefox. I think the network connection is problem and available for P10. However Powerplay still offline when I check status via "Connect to PS GlobalNet "

P10.jpg.

Connect-to-PS-GlobalNet.jpeg

Hi, Ellen

My PowerPlant has also been off-line now for almost 24 hours. I suspect the PS Audio servers are down for a bit.

Elk said

Hi, Ellen

My PowerPlant has also been off-line now for almost 24 hours. I suspect the PS Audio servers are down for a bit.


lol… same thinking with you… whether problem from PS Audio servers…lol

Hi Everyone,

We had to make some DNS changes this weekend which disrupted powerplay. It should be resolved now, although you may not see the changes for a bit until your Internet Service Provider receives the DNS updates. Here is a brief explanation as to why that is. Please note we don’t use NameCheap services, it was just the first concise explanation I found when Googling. If you’re still experiencing a problem with your power devices after you think or know you’ve received the DNS updates please contact our Customer Support at 720.406.8946 or support@psaudio.com. Thanks!

Thank you, Kevin.

Everything is back to normal for me.