Bridge won't work at >44.1kHz&16bit


#1

Hi,

Every track checks out, minimserver scan doesn’t throw up any weirdness. Strangely CAN play DSD and 44.1/16 PCM. But when I try to play a PCM file at anything higher I only get silence and the thing sort of dies.

The “elapsed time” slider on the DS keeps going regardless of what I do to the controller (tried 8player, Kinsky, Songbook, eLyric, all the same result).

My minimserver is the latest version and bridge fw is 0.2.1 or 0.2.15 The server is not running anything else other than miniserver and other mac OS gubbins that comes with Yosemite.

[I know the latest bridge fw is 0.2.15 but I cannot seem to do the upgrade. Pressing the touchscreen to “update bridge” gets “finding update” and it takes a long, long time and finally it says “no update found” atop a blank progress bar and then restarts itself (going back to the “initializing” screen again).

The crazy thing is, I can press the pinion/gear icon once and I get “Bridge: 0.2.1” then click the [back] button, click the gear icon again and it will show “Bridge: 0.2.15”!!!

So anyway, I have no idea which version I have, but accessing the bridge through a browser seems to say it’s 0.2.15 so I’m going with that.]

So back to the problem. When I play a .dsf file, the DS shows that’s it’s PCM for a few seconds then it correctly identifies the track as a DSD track. Which is great so I think I have minimstreamer setup right.

When I play a 44.1/16 PCM file, all is fine. Then I choose a track that is NOT 44.1/16 and it all goes silent. The DS also displays a sampling rate and bit depth that is incorrect for the file. Choosing to remain at 44.1k and 16 bits most of the time. (sometimes it’d show 24).

While this is happening, I can only stop the time bar moving by pressing the little “pause” button on the touchscreen.

If I decide to choose a 44.1/16 track it plays as usual. Again, going back to higher bit rate PCM just results in silence.

Sadly I cannot tell you how it was BEFORE this as I just setup minimserver literally last night and got DSD to work by transcoding to DoP. Surely that doesn’t affect PCM files, does it?

Can someone please let me know what is going on? I’m really confused…

Thanks and wishing you all a great 2015!!!


#2

Btw, I don’t think it’s Minimserver. I downloaded JRiver for trial and used the same mac mini as a server and had the same problem.

Just for additional information - while there as silence and an incorrect sample rate, the cover art actually shows up on the DS. It’s really odd, it seems everything is working great except there’s no sound!

Another odd thing I noticed - the bitrate display is not showing up correctly on USB, but it’s working okay (as in not silent).

Audirvana: 16/44.1 -> DS display: 24/44.1

but for others:

Audirvana: 24/44.1 -> DS display: 24/44.1

Audirvana: 24/88.2 -> DS display: 24/88.2

Audirvana: 24/96 -> DS display: 24/96

Audirvana: 24/176.4 -> DS display: 24/176.4

Audirvana: 24/192 -> DS display: 24/192

Audirvana: DSD64 -> DS display: DSD64 1bit

Most strangely, I don’t have anything greater than 24bit or any other sampling rate other than 44.1 kHz for 16b bit files. For 16/44.1 files, the same thing happens from iTunes with and without BitPerfect. Happens to pretty much every 16/44.1 files I have.

Most odd this… please help

C


#3

I’m not a Mac user and am not sure how MinimServer interfaces with a Mac (I run it on my Synology NAS). But I recall reading that iTunes up- or down-samples everything to what you have set in a control panel setting, Audio/Midi or something like that. Third-party players (like Audirvana) aren’t affected by this. Worth checking, at least, to see if this is set at 16/44.


#4

Hi magister

thank you for your help. I’m no expert but i think staright out of itunes one is at the mercy of mac os’s midi preference. But other players i tried via usb, namely bitperfect and audirvana have control of what the put out through the usb port. As i haven’t set them to alter bit depth i don’t think they do.

when i tried minimserver via ethernet through the bridge, DSD and PCM 44.1/16 are the only possible formats that play music.

Any how, i will try to edit my posts to a more understandable format and see if anyone has any advice.

many thanks and Happy New Year!


#5

Hello again people,

I have re-compiled my problems so hopefully they make more sense:

1.) Via bridge from my Mac mini running minimserver (0.8-update-54) + ministreamer-0.5 with stream.transcode = def:dopwav,dff:dopwav

I can play DSD64 (don’t have any other rates right now) and 44.1/16 files. This time the problem of incorrect sample rates does NOT occur with 44.1/16 BUT I cannot play anything else apart from 44.1/16 and DSD64. It’s crazy. I cannot play say Apple Lossless 96/24 files or any other sample rate for that matter. All this while this is happening, the display just shows 44.1/16, the timing bar keeps moving but there’s just no music coming out. Once I select another song which is ACTUALLY at 44.1/16 it starts plain again.

Can anyone else running minimserver + bridge + DS let me know if I have something setup wrong? Is this something about the while stream.transcode thing? I’m not a Unix person so I’d really appreciate getting this thing set up right - to these ears, bridge sounds better than my USB set up. I will also shoot an email to the minimserver guy to check this out.

2.) USB from my mac mini, everything plays great. Except for the fact that:

The sample rate seems to be incorrect as follows:

44.1/16 AAC -> 44.1/24

44.1/16 AIFF -> 44.1/16

44.1/16 Apple Lossless -> 44.1/16

All my other file types are 24 bit or DSD and they play and display fine.

So this seems to be a problem with just "AAC" type files. It happens under Audirvana, BitPerfect and iTunes. It doesn't matter if I set BitPerfect "Maximum bit depth" to 16, it just seems to come out 24 bit when it's AAC (only 16 for AIFF and Apple Lossless). Audirvana is also not set to do any conversion, so I'm thinking it's just an Apple thing specifically with AAC. Can anyone please confirm this? Thank you. I have also e-mail Audirvana to as of this is the case.

Anyhow, thank you in advance for your help. I hope I get to the bottom of this soon.

Chaiwat


#6

3.) lastly, the Bridge firmware version seems to alternate betweeen 2.1 and 2.15. I can press the gear icon once and it will show 2.1 and press it again it will show 2.15. I can repeat the process and it will say 2.1

can anyone confirm that this is or is not normal? Thank you :)

Btw:

In response to problem (1) according to Simon (of minimserver fame) this appears to be something with the bridge. Is there any setting of the bridge that needs to be or can be changed? Thank you ;)


#7

Yes this is normal, there is a bug in the display code.

Dennis


#8
Dennis Kerrisk said Yes this is normal, there is a bug in the display code.

Dennis


Thank you. That’s both comforting and discomforting at the same time.

Actaully I have a file here that makes it flicker between 16 and 24 like every 2 seconds or so. Not all that awesome.

As for the bridge problem, could my bridge be dying?


#9

That is a whole different issue. Something is confusing the FPGA as to the the bitdepth in your second case.

Dennis


#10
Dennis Kerrisk said That is a whole different issue. Something is confusing the FPGA as to the the bitdepth in your second case.

Dennis

Oh dear. Is there anything i can do to solve this? It all sounds okay, just the displaying a wrong bit depth...

actually, these files have a really odd “bitrate” information -> 44.1/24 file with 1454.30 kbps? Odd…


#11

Given the bit rate of the files, something is wrong with the files themselves.

I bet they are 44/16 files with an occasionally padded sample which is causing the FPGA to believe it is being fed a higher resolution file. (A 44/16 file has a bit-rate of 1411 kbps.)

I suggest transcoding the files to 44/16 to strip off the extra, spurious bits.


#12

Is there a way i can ‘fix’ these files? If i use minimserver to stream them, they get to the dac as 44.1/16 just fine. Seems to just happen through usb. And it’s not just a couple of files, but like nearly all of them. Oh boy…


#13

Yes. Transcode the problematic 44/24 files to 44/16 with dBpoweramp or other similar program of your choice.


#14
Elk said Yes. Transcode the problematic 44/24 files to 44/16 with dBpoweramp or other similar program of your choice.
Okay will give this a try tomorrow. Thank you for your help :)

#15

I use MinimServer all the time and can play all sample rates to the Bridge, up to single rate DSD via DoP. I’m not sure what about your setup would cause your problem (1) since I don’t use a Mac.

Are you using any transcoding settings in Minimstreamer? If, so have you tried turning them all off? If not, that would be the logical place to start, I’d think. See what happens with no transcoding. Then add the settings back one at a time.


#16

UPDATE

1.) I think I’ve solved it - the bridge thing at least.

The good news is that the bridge is working. The other is there does not seem to be anything minimserver-related. I tried streaming 96/24 to my Oppo 105 and it works fine -> it’s something with the bridge and how the bridge woks.

The other sort of good news is that the files that would not play over the bridge was identified to be anything “Apple Lossless” that are OTHER THAN 44.1/16. That is to say if it’s Apple Lossless + 44.1/16 then it works fine. But if it’s Apple Lossless at anything else, I get silence.

My solution was to go back and converted all offending files to FLAC. Which took a while, but everything is now working through the bridge. The bridge is now showing the correct bit depth.

It’s weird - most of these tracks I purchased from HDTracks. But anyway, Simon (of minimserver) says there are 2 places in Apple Lossless files which may contain the bit depth/sample rate information. The bridge was probably looking in the wrong place. They play over USB as the bridge is by-passed. This is a ‘probably’ and I’ve sent him a file so he can have a look.

2.) The weirdness remains. If I convert the files to FLAC, the display shows the correct bit depth.

3.) When I access the Bridge through its IP address, it says 2.15a so I’m not too worried.

Anyhow, thank you for all your help, I will keep you posted on progress if any further is made. If anyone has any new ideas, please let me know :)

Chaiwat


#17

Excellent progress and great to hear you are on track.