D.O.A.


#1

Hey, folks.

I received my new Sprout, yesterday, which I ordered from Amazon. Excited as all heck to give it its inaugural whirl, I plugged it into the wall, turned it on, and… nada! No juice. I tried several electrical outlets (all properly grounded), and three of the four stages: digital, analog, and Bluetooth (I own no turntable). The digital source was my PC by way of USB. The analog source was my iPhone by way of its headphone jack. The attempted Bluetooth sources were my PC and my iPhone. I say “attempted,” because since the amp has no power, it obviously failed to broadcast its existence to my Bluetooth sources, so connection wasn’t possible. In all cases, neither my speakers nor my headphones ever made a peep.

I wondered if the power cable might be faulty, so I swapped in one from another piece of equipment – no dice. Then, in desperation, I wondered if maybe the power on/off switch had been installed backwards, so that “1” meant off and “0” meant on, so I repeated all of the above tests with the switch set to “0” – no luck.

Is there some sort of lockout that I need to remove before the thing will work, like on some kids’ toys, or is the thing just dead?

I hope someone has an easy solution of the “Yeah, just do X and you’ll be good to go!” variety, because I really don’t relish the prospect of returning it and then waiting for weeks to get it back in working order.

Thanks very much for any and all help.


#2

No, it should just work. One of the problems with Sprout is there’s no indicator light so you don’t know if it’s on or not. Chances are really good that it is working, though. Each Sprout is 100% tested before it leaves the factory and DOAs are unheard of.

What are you connecting up to the speakers?

Of course there’s a chance it isn’t on at all - it should get warm on the top or bottom of the unit if it’s getting power - give it an hour and see if it’s still stone cold.

We can certainly get it fixed for you on Monday if not.

My apologies.


#3

Hi, Paul.

Thanks for your lightning fast response.

The speakers are Thiel CS 2.2, connected to the amp with banana plugs. They work fine with my old amp (though not as fine as I hope they’ll eventually work with the Sprout :).

I’ve plugged it in and turned it on, and I’ll get back to you after lunch (Eastern Daylight Savings Time) with the results of the heat-test.

Thank you.


#4

Yeah. If it’s stone cold, give us a shout on Monday (phone number’s at the top of this page) and we’ll get you a new one ASAP.


#5

Welcome, K-town!

A tough beginning, but I’m sure you will be pleased once you get up and running.


#6
Paul McGowan said

Yeah. If it’s stone cold, give us a shout on Monday (phone number’s at the top of this page) and we’ll get you a new one ASAP.


I’m afraid it’s still cold after almost two hours, so I guess we’ll have to pin this one on a rough ride during shipping, since the inspection certificate that came with the Sprout says that it checked out A-OK before shipping. I’ll call your customer service line tomorrow. Thanks for your help.

#7
Elk said

Welcome, K-town!

A tough beginning, but I’m sure you will be pleased once you get up and running.


Thanks, Elk.

And yes – of that, I have no doubt. Based on the many reviews that I’ve read from sources I trust, it’s as if the Sprout were custom-made for me.