Direct Stream Sr STUCK!

Hi guys… hope you can help. I purchased new a BHK Pre, DS Memory Player, and DS DAC back in the fall and have finally moved into my new house and was using the long weekend to setup my audio room. The BHK-Pre and DS-MP came right up but the DS-DAC did the initializing screen bar went only about a 1/4" then started over and 1/4" again then started over and went the full length then came up to what I assume in the home screen. The touch screen does not respond and the unit will not respond to the remote. I have re-booted multiple times with the same result. the standby button has now effect as well… HELP!

Turn off and unplug the DS. Take the SD card that came in the box and after fully formatting it download Snowmass and install the files only on the SD card. Plug the DS back in, insert the SD card pins up and turn the DS on by the back switch and see if it updates and boots up. If it does take out the SD card.

If you pull the SD card and let it boot it will boot up with loaded software. This will break the loop. You can then load current version of choice.

Hi guys… Thanks for the idea of re-booting from the SD Card w/ Snowmass unfortunately no change! Still no response from the front panel or remote. More ideas? This is really frustrating as I am only home a few days a month and crap no music after waiting for so long. I leave again tomorrow (Tues AM). I just hate DOA stuff.

Understandable. Hope you get it sorted out soon.

If you have the DMP connected via I2s try disconnecting the cable on the DS end and see if it will boot up with no SD card in the slot.

Dawkinsj… Good idea, I was using the I2s and have now disconnected the inputs to the DSD but upon reboot same state. No response from the front panel or remote. Ugh.

Very frustrating. :frowning:

Update… I have removed the Bridge-II, disconnected all inputs, and have downloaded the latest firmware and installed onto multiple SD cards. Ten (10) attempts to re-upload Snowmass from SD card(s) then try to let the DSD boot without the SD card. In all cases the same response.

  1. initializing stalls at 1/4" then retries a 2nd time and stalls at the same 1/4", then retries a 3rd time and finishes. The screen comes up to Coax input & 25% volume with no response from the touch screen, remote or standby button. Standing by for direction from PSA. Ugh. Wife standing by to send back while I am gone this week. I’m home next weekend then gone for 3 weeks. Hope PSA can have me running by Fri night when I get home.

Testing my memory here, but if I recall there is a microprocessor reset procedure. With the DS switched off at the back, press in the blue PS logo on the front and whilst continuing to press, then turn on the main switch at the back. Wait a few seconds and then release PS logo button. But don’t rely on my memory, do a forum search on the procedure. If your DS goes puff, at least it’s in warranty.

Brodic… Again another good idea. I had already tried the hold the PSA Standby button while cycling power. It brings up a screen that asks to press the 4 corners in order (numbers on the screen) to determine up from down. I know this because if you push out of order the display will invert (upside down). Then you have to do the process again and go out of order again to get the screen rite-side up. None of this nor subsequent reboots - snowmass reloads have made a difference. I do appreciate the good ideas though!

Argh right, that does do the DS touchscreen calibration.

In the DSJ it resets the micro.

Dunno why they do it differently between the two DS models.

You might try installing an older firmware version. It generally will not re-load the same version as is installed (unless it is a force load set of files). If that works, yo can go back to Snowmass.

Just tried loading snowmass 3.0.4 (older version) with no change / no response from the screen, remote, standby button.

Try a non v-3.x

You need to snap it out of its present state of mind, try Huron or something. Once its foggy brain is cleared you can then put SM on it.

I tried Yale and Huron… no change.

So here is what we do know at this point:

  • The touch screen does work because I can adjust in screen cal mode
  • The SD card slot works and different firmwares can be loaded (some come up at 100% volume while others come up at 25%)
  • The standby button is functional since if I depress it and power on the unit enters screen cal mode
  • Once the DSD boots no response from the standby button, screen, remote.
1 Like

Hopefully I’ll get something from PSP on Tues when they are back from the holiday weekend.

You are very close. Perhaps a force load will take care of it.

Please let us know what you learn from PS Audio and how your issue is resolved.

Did the DS Dac ever work, or is this the first time you’ve fired it up?