Direct Stream USB Audio device dropping on Mac


#1

I currently have a MacBook connected to a DirectStream Senior via a Pangea Audio USB cable. I have noticed that the PS Audio device will disappear as a USB Audio device from a Mac perspective and audio will default back to the internal speaker when my Mac goes to sleep and I have soft powered down the DS overnight.

When the Mac wakes up and I power on the DS the Mac no longer sees the DS. Unplugging and plugging the USB Cble does not resolve it. Only a power recycle from the back power switch on the DS allows the DS to be recognized again.

This has only happened twice over the past two weeks so it’s not consistent.

Any thoughts as to what may be causing this?

Thanks, Alan


#2

This issue has been discussed previously. My DSJ exhibited the same behaviour. You’ve discovered the solution.


#3

Do you know if this is a general USB handshake problem or a problem with the DS? Rebooting is a bit of a pain especially for family members who just want to play music.

I did search before posting and didn’t see the old thread.

Thanks, Alan.


#4

As I recall there was never a definitive answer on this issue. It was left with an interim solution to reboot the DAC. The problem is in the DS: my Esoteric DAC and Ayon DAC do not have USB/Mac issues.


#5

I am having a similar issue with my Stellar GSDAC. My IMAC does not recognize the the GSDAC while there seems to be no problem with my Oppo HA-1. I have unplugged USB cables, restarted MAC, restarted the GSDAC. These tricks have worked in the past, but it is a PITA, now however nothing is getting the music flowing. Any help would be appreciated.


#6

@jgiese,

Were you able to get your issue resolved? Did you call it in to support? Unfortunately there doesn’t seem to be a good solution. Since I have a DS with the bridge, I have pretty much started using the bridge exclusively to work around this issue. I don’t think you have that option with the Stellar.

@Paul, is this on an issue list somewhere to be worked on?

Thanks, Alan


#7

Thanks for the response. If I disconnect all USB cables from the MAC and then restart I sometimes get the computer music going. Yes with the Stellar pre I don’t think I have the bridge option. I wonder if the “BitPerfect” app could be a contributing factor . All in all though , the whole computer audio trip is a pain as compared to the sound of CD with my “new” PWT and Stellar GSDAC.


#8

I have no problem connecting or having my Mac see the USB driver, ever. Maybe there’s something wrong with the unit? Did you in fact contact our support?


#9

As I recall (vaguely) from long ago when I used the USB connection it helped to set the Mac so the computer itself never goes to sleep. The screen and hard drive can be put to sleep, however. Did anybody try that?


#10

I had the same problem with mine, others have also reported similar problem. The DS and Mac just stop communicating with each other over USB. Using the same Mac and USB cable, never had an issue with my Esoteric or Ayon DAC. This suggests the problem is in DS.

Bugger: I just spilled hot tea all over my Mac keyboard…


#11

I filled out the form on the “service” tab in the resources pull down. Of interest, I have pulled all other USB cables from the MAC and today things are woking.


#12

“Bugger” turned out to be an understatement. The MacBook Air died from a fatal dose of morning cup to tea. Apple Genius Bar says not economic to repair. Oh well, $1,799 for a new MacBook Air. Take it home to do a Migration Assistant from Time Capsule to find that TC had not done a single backup of my Admin user account in past 4 years. 4 years of holiday photos of my 2 kids growing up, website passwords, and work etc etc, all gone.


#13

Truly dreadful. :frowning:


#14

I must have been a wicked person in a previous life and the karma gods are taking retribution on me time and time again. My Kaleidescape server had a double HDD failure a few years ago and I lost RAID. Out of a world-wide fleet of millions of hours in-service with this system a double HDD failure had never occurred before. I had to send the HDD set to the US for data recovery, and fortunately they were able to restore most of the file system. So I didn’t lose much content at all.


#15

That really sucks. Can you pull the drive out of the Air? Or is t fried too?


#16

I called the tech help people at PSA today and would like to thank them. James suggested I power off the GSDAC at the rear power switch instead of using the remote to put it in sleep mode. On powering up the GSDAC my IMAC recognized it.


#17

I can’t do anything until I can get my hands on the tool to open it up and try…it’s proving problematic to find one.


#18

That has been the solution for everybody else, however why it does this, when other DAC’s don’t, requires attention.


#19

When I spoke with PSA tech today they said they were not aware of this problem.


#20

if they are not aware of the problem that is a problem. Because the problem has been known about for a long time. I first reported it about 2 years ago.