DirectStream DAC bridge II directly to NUC running WiFi possible?


#1

Hi experts,

I have a challenge, that I hope you can help me with!

I have bought a Directstream DAC and an Intel NUC, and am now trying my best to get them to function together through the Bridge II connection. The setup is looking like this:

PS Audio DAC <–> Bridge II <–> Ethernet cable <–> Intel NUC with local music storage running ROON ROCK <–> Intel NUC WiFi <–> WiFi router connected to internet <–> iPhone 6 with ROON remote

The idea is, that I want the direct ethernet connection between the DAC/Bridge II and the NUC, and want to access the ROON core using the NUCs WiFi instead of adding a switch in the setup.

I read that someone managed to make the direct ethernet connection, so I guess my problem is using both the NUCs ethernet and WiFi at the same time? Can this be solved?

I have set the ethernet IP to be static in Roon ROCK, and am putting those data into the DAC, so that they match. I have tried using both a normal ethernet cable and a cross-over ethernet cable.

The ROON remote can connect to the ROON server, but find no devices directly connected to the core.

Any help will be much appreciated!

Best regards from Dennis

Unfortunately I can’t put more than one image in the post, since I am a new user… The image below is from the remote ROCK access, where I am defining the IP to be static. The exact same data I put into the Bridge II.


#2

It’s known as bridged or routed network interfaces. Have a look at this thread over at Roon forum. https://community.roonlabs.com/t/bridging-network-interfaces/19233


#3

Hi bbarden,

thank you for the reply. The thread you are linking to is not helping though.

I have some further information that might help you experts to help me:

Currently it is set up as follows (and it is not working):

Networking - Ethernet (ROCK):
IP Address Setup: Static IP
IP Address: 192.168.8.104
Netmask: 255.255.255.0
Gateway: 192.168.8.2
DNS Server: 192.168.8.2

Networking - Wireless (ROCK):
IP Address Setup: DHCP
IP Address: 192.168.8.107
Netmask: 255.255.255.0
Gateway: 192.168.8.1
DNS Server: 192.168.8.1

Networking - Bridge II (DirectStream DAC):
IP Address Setup: Static IP
IP Address: 192.168.8.104
Subnet: 255.255.255.0
Gateway: 192.168.8.2
Primary DNS: 192.168.8.2
Secondary DNS: 192.168.8.2

If you would type in what numbers I should use instead, I would be VERY grateful!

Best regards
Dennis


#4

Impossible to solve the whole problem without knowing your network; however, you have the Ethernet (ROCK) and the Bridge on the same IP. Two devices on the same IP is never good.


#5

I can help you. Two things are incorrect. You’ve got an IP address conflict, and your two network interfaces are using the same subnet.

Change Ethernet ROCK to use:

IP Address 172.16.1.1
Netmask 255.255.255.0
Gateway: blank, as in no value, it’s not needed
DNS: blank, as in no value, it’s not needed

Change Bridge II to use:

IP Address 172.16.1.2
Netmask 255.255.255.0
Gateway: blank
DNS: blank

Leave wireless unchanged.


#6

Hi Bbarden,

thanks for your fast reply. I have tried what you are explaining and manage to get the connection up and running for a little while (the red LAN icon on the DAC change to green). But when I connect to the NUC via the ROON app on my iPhone, either the connection to the ROON core is lost or the connection between the NUC and Bridge II is lost (the LAN icon changes from green to red). Even when I manage to open the ROON app on my phone while the LAN icon is still green, the DAC doesn’t appear as a possible device to chose - and shortly after the icon turns red and the static IP settings are changed back to DHPC.

Below a screenshot from my iPhone, where it can be seen that no connections are registered to the core or on the network.

Have you got any more ideas?


#7

Here a screenshot of my wireless settings in the ROCK:


#8

I’m afraid I don’t have any other ideas. I would stick a small Ethernet switch between ROCK and Bridge and connect it to rest of network, in other words the standard supported configuration. Try a linear power supply feeding the switch to see if you can tell any difference in SQ.

In my experience, having a switch has caused no SQ impact. If there is any, it’s far less than speaker placement, source quality, etc.


#9

Not enough time to design this out entirely, but the first responder was absolutely correct. Do not configure the same IP on two devices, all IPs must be unique.

Second, I’m not clear why you’re showing two different gateway addresses/DNS server addresses. “.1” is the most common, and I see it’s what you’re getting via DHCP (assigned by your router). Why did you use “.2” for the other devices?

Basically, you’re “bridging” networks here, not routing. Because of that, it’s essentially “one bigger network”. I’d expect you to need to use the same gateway/DNS IPs on all devices, and what’s delivered via DHCP is probably the correct one. If you were routing (using the NUC as a “router” which directs traffic between two different network “segments”), whole different story.


#10

Hi,

Thank you for your feedback - I really would like to avoid putting another switch into the mix - even though that would most likely be the easy thing to do… Are you guys sure that it is not possible to do what I would like?

I have now tried to put in the following network settings and checked that my router is using 192.168.8.1, but it is still not working - the roon remote loose its connection to the core and the network icon is staying red on the DAC.

Networking - Ethernet (ROCK):
IP Address Setup: Static IP
IP Address: 192.168.8.104
Netmask: 255.255.255.0
Gateway: 192.168.8.1
DNS Server: 192.168.8.1 / 8.8.8.8

Networking - Wireless (ROCK):
IP Address Setup: DHCP
IP Address: 192.168.8.107
Netmask: 255.255.255.0
Gateway: 192.168.8.1
DNS Server: 192.168.8.1

Networking - Bridge II (DirectStream DAC):
IP Address Setup: Static IP
IP Address: 192.168.8.106
Subnet: 255.255.255.0
Gateway: 192.168.8.1
Primary DNS: 192.168.8.1
Secondary DNS Server: 8.8.8.8

So I have scanned my network with the Net Analyzer - see pic below:

Are the any faults in the above or other things I can try?


#11

Did you try bbarden’s recommended settings with the crossover cable? This cable should be used between the roon and the bridge.


#12

Despite reading your opening post several times I still don’t comprehend what you are trying to do, or why.

You want those mentioned devices on your network to be able to communicate with each other, right? And you particularly want the DS and NAS to be hardwired together directly, and then use the WiFi of the NAS to connect to the network, right?


#13

That is exactly right :slight_smile:


#14

When I use a ethernet cable from DAC to the WiFi router, everything is working fine and I play music through the DAC from Roon Core using the remote on the iPhone - no problem. But when I use the cable from DAC to NAS, then I cannot make it work, and thats the problem because I cannot have an ethernat cable permanently installed between DAC and WiFi router.


#15

Connect an access point configured to client bridge mode to the DS and your installation will behave exactly as it does when you use the ethernet cable between the DS and the router. A Pakedge W7 will do the job. You can find them on eBay for $20. Buy a 2nd one and disable the WiFi built into your router and you’ll really be cooking with gas then.


#16

Hi Brodric,

yes, i believe you that it would - but that would mean that I am not directly connecting the NAS and the DAC, and instead I bring in an additional “switch” (or accesspoint) and power supply, which is exacty what I would like to avoid - if possible! It seems that people have been able to do the direct wiring between the NAS (Roon ROCK) and DAC, which is why I am aiming for that.

If I really have to go for a lesser solution, I can just hardwire the NAS and DAC using USB, and then connect to my WiFi network using the NAS. Then I have a Bridge II card I can throw out the window… Alternative I can use an access point that I connect the NAS and DAC to with ethernet cables, and it can then connect to the WiFi. This would require the additional power supply - Also not great. But if there is no other way…


#17

I don’t know anything about your NAS. But if your NAS was my MacBook, its ethernet port would connect to DS, and its WiFi would connect with the network. All network clients would communicate with each other quite happily. Suggest you lodge a support ticket with your NAS manufacturer and have them offer a solution. I’m sure what you want to do can be done.

I connected my DSJ to a network switch. I don’t know why your aversion to using a switch.


#18

OK, I’ve requested information about this before, but I have only received bits & pieces toward a solution. I am not very network savvy & want to connect my MAC Mini to the Bridge 2 directly. I too prefer not to introduce any extra components if I don’t have to. Can someone point me to a step by step procedure for accomplishing this? I have both standard & crossover ethernet cables & am using JRiver MC23 on the MAC running High Sierra. My music is on a USB drive connected to the Mini. The Mini is connected to my WiFi network FWIW.
I want to try this & compare the experience to my USB connecting to the DS DAC.
Thanks,
Kev


#19

I did this semi-successfully, but haven’t had time to go back and see if I could get it “completely” working.

What I did:

– added a usb-ethernet port to the NUC; connected to my network switch (for access to my NAS and internet for streaming and for the management interface of ROCK)
– connected the NUC built-in Ethernet directly to the DS (not a cross-over cable, the NUC is able to auto-determine and adjust)
– set static IPs on the NUC Ethernet port and the DS, on a 10. network
– allowed the USB-Ethernet port on the NUC to get DHCP from my home network, which is a 192. network (so in essence the NUC was routing, not bridging, between the two network it was attached to)

All of this worked fine. The part I didn’t get working was ability for the DS to see my home network. I think it was just I didn’t configure the gateways correctly, but in theory no reason once I got that sorted all shouldn’t work in a way that’s similar to what you’re trying.

Rather than trying with wireless (which is questionable in terms of the effect it might have on signals within your NUC), maybe try the usb-ethernet method I tried out.