DS junior no volume control throug mcontrol app

Hello PS audio community.
U recently upgraded to the Windom firmware. Sounds great!
What I have found, is that I can no longer control de DAC-volume, when I am streaming through the Mcontrol-app. I have used 2 differtent Iphones and an Ipad. Same result.
What is strange though, when I change the volume on the DAC, or via the remote-control, the Iphones and Ipad do recognise these changes, and adjust volume accordingly on the screen. So volume control is linked from DAC to Iphone, but not from Iphone to DAC.
What may be the possible cause of the problem? I can not remember if the problem immediately manifested itself after the Windom-upgrade, or a bit later on…
many kind greetings

See above. Problem keeps occuring. No suggestions?
Kind regards

Is your usb-card in the slot at the back of the DS? If not, insert it and try again…

Hello Wijber,
thanks for your input.
You are referring to the actual Bridge-card? Because I’m not exactly sure what you mean. Last week (without making any modifications) the volume-control on my iPhone did work for one night, but yesterday-evening, again, the same problem manifested itself.

I experienced the same problem using BridgeII in the past (now going usb-matrix-hdmi). Locking the sd card back in the slot at the back of the DSsr (not in the BridgeII but in the slot one also use to update firmware) solved it.

EDIT; sorry, just saw you’re using the DSjr. No experience with this one but you could try with the usb stick inserted…

Hello Wijber,
yes, DS junior :wink:
I will try your suggestion later on, and report back after that.
have a nice day!
kind regards, Gunter

I have the same problem. DSJr, upgrade to Windom, no volume control. Any fixes?

Hello Matt,
The problem keeps occurring. Also, the mcontrol-app seems to lose the connection to the bridgeII quite often. Even after resetting router and switch, the mcontrol-app cannot find the bridge on the network. After a while it seems to re-appear all by itself. I find that in that instance, the volume-control does not work. After a few days, the volume control magically starts working again. And then the mcontrol-app loses the bridgeII again, and I can start all over,…
very frustrating!

If you were to roll back to Snowmass, would it start working again as expected?

I would only know that untill I did roll back to Snowmass, James.
Could changing over to a static IP solve these connection issues?

Great idea! Certainly a good thing to try, but no guarantees it’s the fix. Give it a shot and keep us posted.

Hi Gunter,

This is the first I’ve heard of this issue. I’ll have the engineering team look into it and see if we can recreate and resolve it for you. Correct me if I’m wrong, but it sounds like you may have two issues:

  1. Volume stops working from the app (If you cycle inputs on the front back to bridge does volume work again?)
  2. Unit disconnects and connects randomly from the network.

Did both of these start after installing Windom?


Hello Matt,
sorry for the late reply.
I can not give you input regarding the Windom installation, because I only recently acquired the Junior, and immediately installed the Windom update. My best guess is that the problems occur when my router issues the IP address to the junior if the LAN cable was detached, or when the router was rebooted for some reason. Then again, last week, I installed ROON, and it seems that the connection is much more stable now, so the culprit could very well be the mcontrol-app, which has trouble connecting to the bridge if the IP was re-issued. I will keep monitoring, and report back if needed.
Thanks again for the support!

I’ve been using Roon for a few weeks now, and I have encountered zero connection issues. I must conclude that mcontrol is the culprit here…

I bought my DSJ with snowmass already on it. Volume control issues with the app when I installed Windom. I installed Red Cloud and had no volume control issues. Re-installed Windom then the volume control issue came back. Turns out all it took was toggling the DAC input from Coax to Bridge for the volume control to work. Turning the machine on and off did nothing. Just toggling the input.