DS Remote has become non-responsive


#1

The remote control for my Directstream has recently become non-responsive. Pressing a source button multiple times produces no change in source on the DAC. Eventually after many firm presses and placing the remote close to the DS, the input will change. I have tried the usual remedy of swapping batteries but this makes no difference.

Before I take it back for a service, has this happened to anyone else and it there something stupid I might be doing or missing?

Any suggestions gratefully received.

Regards,

Chris


#2

That’s a new one. Have you tried rebooting the DS? If rebooting and batteries do not work, I would think we should mail you a new remote first. I would suspect the remote before the hardware itself. Call us and we can get one to you.


#3

As Paul suggested, try the reboot first. I noticed on my PWD (started as Mk I, then modified to Mk II, then DS) that sometimes after a reboot the touchscreen would need a lot more force on the touchscreen to work. I mean a LOT of force, like almost-break-it. I learned that when that happened, merely rebooting it would solve the issue. I think the remote sensitivity dropped as well, so the remote had to be within inches of the unit to work.

So try a reboot and see if it gets better. If not, try the new remote and go from there.

Sorry about the frustration. Best of luck.

–SSW


#4

If that doesn’t work you might try installing a different firmware version in case some code got corrupted. You can then go back to Pike’s Peak or whatever you are using.


#5

Chris-

Check that the IR window on the front of the DS isn’t dirty - just wipe it with a soft, clean cloth.

If you have a universal learning remote or have access to one, try transferring the DS remote programming to it. If the learning remote detects a signal then you’ll know that the DS remote really does work. Also, the learning remote may have a stronger output that the DS will be better able to detect.

It’s also possible that the connection from the board to the IR receiver is loose or that pickup behind the little window is out of alignment. You might try cracking your DS open and wiggling the wires a bit. The first video in the DSD installation guide shows how to get the beastie open.

Good luck!

-Pb


#6

Thanks for all the suggestions. I will give the reboot and clean a try.

Cheers,

Chris


#7

OK - all fixed. I should have realised that turning it off and back on would do the trick! Who’d have thought it…

Chris


#8

It is a computer. A reboot can work wonders.

Good to hear everything is back to normal.