DSD indication on DMP screen


#1

When I play a hybrid SACD with Stereo SACD chosen in setup, I’m seeing PCM as the output on the DMP.

Shouldn’t I see DSD as the output?

I’m using the I2S stereo front channel connection to my DSD.

Thanks

John


#2

John,

Try turning off both DMP and DSD and disconnecting the HDMI cable then reconnecting and turning both units back on. Sometimes that corrects the connection for SACD.

If that doesn’t work there may be an “ID” problem, and PS Audio Support can help provide the ID when the DMP is connected to the internet. . . a call or email to them can help get that accomplished. I had that ID problem and I was helped by an email on a weekday, was very fast and easy to accomplish.


#3

I had the same problem, DSD unit had no ID. With PS Audio support it was accomplished in very short notice. Look on your set-up screen (touch upper left) It says Huron and Unit ID: No unit ID no SACD handshake protocol.

Ronald


#4

Thanks to both of you for the suggestions. The reboot of both units (one at a time) did not help. My DSD has an id #, but I’m not connected to the internet yet. Is that necessary for the correct fx of the DMP? I’m using a Wireworld silver starlight 7 HDMI cable. But that works just fine for redbook cd’s.

Any other ideas? If not, I’ll email Jeremy Brety tomorrow.

Cheers,

John


#5

It is not necessary to be connected to the internet. If you can see your ID for DirectStream, which means it’s recognized and connected, and you make sure you’re using I2S between DMP and DS, then the only other thing I can think of is to make sure in the DMP setup that you’ve selected SACD to be rendered as DSD and not CD. I don’t remember exactly where in the setup menu it is, but there’s a setting. Just look and you’ll find it.


#6
John Wyant said

Thanks to both of you for the suggestions. The reboot of both units (one at a time) did not help. My DSD has an id #, but I’m not connected to the internet yet. Is that necessary for the correct fx of the DMP? I’m using a Wireworld silver starlight 7 HDMI cable. But that works just fine for redbook cd’s.

Any other ideas? If not, I’ll email Jeremy Brety tomorrow.

Cheers,

John


Well, reboot both units BUT be sure to physically disconnect the HDMI cable and reconnect–that did the trick for me the second time I had a problem (after the ID issue).

#7
lonson said

Well, reboot both units BUT be sure to physically disconnect the HDMI cable and reconnect–that did the trick for me the second time I had a problem (after the ID issue).

Yes! If that doesn't work, try the other port on the DS. Also try a different cable.

The setting Paul mentioned:

Touch the three dots (…) in the upper right-hand corner of the DMP screen -> Touch the pencil (edit) icon -> Touch the blue arrow to the right of “SACD Mode” to toggle through the setting until you reach “Stereo SACD”


#8

OK, I think I found the problem. I checked again and I have a unit ID on the DSD, but I have a blank space on the DMP.

So, how do I get one for the DMP?

Thanks,

John


#9
John Wyant said

OK, I think I found the problem. I checked again and I have a unit ID on the DSD, but I have a blank space on the DMP.

So, how do I get one for the DMP?

Thanks,

John


Hi John,

Please reach out to us at service@psaudio.com or call us at 720.406.8946 ext 2.

Your DMP should have a unit ID and from what you say it does not.

We can send you a web tool to update the DMP remotely.

We just need your serial number.

Thanks,

  • Jeremy

#10

Hi Jeremy,

The product is registered at PSA with correct serial number.

I have an email in to your associate, JamesH at PSA. Hopefully, we can get my DMP straightened out.

Cheers,

John


#11

Problem solved!

Apparently my DMP, bought direct from PSA, left the factory without an ID#. With the help of James Herod in customer service, over a few hours, I got an antidote for my DMP. I was guided step by step thru the process. At first, I got an error code and nothing worked out, but we finally decided to turn off my Norton firewall and bingo, the DMP rebooted with an ID#. I cannot complement James Herod enough, hanging in there with me for hours, on and off the phone. Needless to say, I am very pleased with PSA’s customer service, and this is one reason why I own several PSA products, and undoubtedly will own more.

I was on the verge of sending the DMP back to PSA, as it didn’t really best my PWT.

Tonight I’ll reconsider, and listen to an SACD for the first time in my system.

I’ll get back about that, but my expectations are very high.

Thanks for all the help from everyone,

John


#12

Great to hear!

Let us know your reactions after you get a chance to relax and listen.


#13

Great news John. And no surprise that customer service was so helpful, that’s been my experience as well!

In a week or so I bet the DMP clearly bests the PWT.


#14

OK, I got around to listening to the DMP after running a burn in cut on repeat for 48 hours or more.

The DMP certainly is better. -More everything: bass, rich full mid-range, imaging, depth, sounstage, etc. -Basically a more relaxed and realistic listen.

It’s a keeper, and the PWT gets sent back to PSA.

Thanks,

John


#15

Awesome to hear John!!

I’m glad we were able to work out the minor kink, and that the DMP and DSD pair are sounding Great!


#16

dancing-009_gifmusic-078_gifhappy-132_gif


#17

greetings fellow PS fans. maybe this will be of help as well and i thank the posts above for their help. my power went out for a couple of hours, and when it came back on i fired the system back up. for some reason the DMP only showed a white screen and no amount of turning it off and rebooting helped. so i turned if off again (always with the rocker button) and then i unplugged the HDMI cable. turned it back on and voila there was a blue screen again. Turned it back off, plugged in the cable, and it came up correctly.