DSD Logo flashing, will not boot

Tried search, results unsuccessful. Hoping one of you has experienced and resolved similar situation

System had been unplugged for a month or so. Upon power up logo button lights blue and flashes however DAC does not boot.

Powered off, unplugged, rebooted with SD card removed. No change

Reformatted SD card, powered up, no change

Because DAC has not rebooted it does not respond to the remote. I expected this but I am out of ideas

Compact Snap (2)

Sorry to hear this. If all attempts fail, would try reinstalling the firmware! Others may have better solutions.

You might try holding the logo button in while powering it on. This is usually a little deeper reboot process. Not sure if it applies to the DAC or not.

2 Likes

Thanks for that! I have just learnt something new.

1 Like

My power plants will freak out once in a while after a power outage and not restart correctly.
I hold the blue button in, power the main switch on, then release the blue button when the “initializing” message comes on.
I believe this process will work with most of their devices. It might not resolve the OP’s issue but is certainly worth a try.
.

2 Likes

Thank you for the input

I have tried a different SD card, formatting both on mac laptop as well as windows laptop, even tried holding power button (front panel)

Still same result. flashing blue light but boot progress - even after 15 minutes

I suggest giving PS Audio a call.

This is pretty odd as I’ve never heard this happening without an SD card in there. My guess is the software is corrupt. Give our service guys a call and they’ll be able to get you going again.

I am having this very problem as well after loading a CD into a new PST. The DSD DAC standby button is flashing blue. Down powering the DSD and the PST have no effect what so ever. Will try a second cold boot.

Sorry to hear that, Certainly puts a damper on the excitement of listening to a new piece of audio equipment!

That’s a new one. You don’t have the SD card plugged in do you? Also, what happens if you unplug the I2S cable?

I’ve been on the phone with Mark in tech support. My DAC is dead, and the transport is not consistent in reading CDs/SACDs or USB. It required a cold reboot to read CDs or an SACD this morning. After inserting a CD and attempting to play the DA flashed at me, there was a squeal, and repeated attempts to cold boot the DAC have been unsuccessful. The SD card is not seated in the receptacle. At this point the DAC and transport are unplugged and will remain so for an hour or so. I will then re-power both, and hopefully they boot up and work properly. Otherwise they maybe coming back to PSA.

1 Like

So sorry to hear this! I feel for you and hope you resolve the issue(s) soon.

Man, that sucks! I feel kind of lucky in an odd sort of way.

Very sorry to hear this weedee. This really stinks and I hope it’s nothing serious. No matter what, we’ll make it right for you. Mark has the freedom to do whatever it takes to make you happy so I know he will work hard for you.

4 Likes