I think my Stellar GCD USB port is dead


#1

I was blaming it on my Allo USBridge, but everything seems to be working fine. I’ve tried multiple cables, but neither my iMac, nor my PC is detecting it. :frowning:

Toslink works. This is strange.


#2

Have you flipped the power on the back yet?


#3

Yep, several times.


#4

Try another cable?


#5

Tried 2. Both brand new.


#6

Try an alternative Usb source ?


#7

Allo, PC, and iMac all not detecting it…


#8

That’s odd. I think there’s likely another answer. Can you contact Jeremy in service? He’s likely to get you sorted out.


#9

Have you tried a factory reset of the unit? Also, how long are these USB cables?


#10

I was looking for a reset button but couldn’t find one. I’d like to try this.

One is a cheapo 6’, one is a decent quality 3’ Pangea.

Both cables have been working fine in the setup up until now.


#11

Both of those should be fine.
Turn off the rear switch., hold down the logo button, and then switch the unit back on while you’re holding the button down. The unit will then tell you it’s doing a factory reset.


#12

Thanks! I’ll try a factory reset when I get home.


#13

Fingers crossed . . .


#14

Factory reset: Held the blue button down, powered the unit on from the rear switch. It said factory reset. I released the blue switch. It rebooted. Still nothing. Nothing is detecting the DAC. I’ve reset it several times.


#15

Did you ever try the YouTube suggestion to see if it is a setting in Audirvana causing the issue?


#16

No Audirvana in sight. Multiple devices do not detect the DAC


#17

Go ahead and shoot our tech support team an email, and see if they have any ideas for what could be going on. service@psaudio.com


#18

I fillledbout the service ticket Last week, but haven’t heard anything back.


#19

Try contacting our manager directly. jeremyb@psaudio.com. Sometimes the emails going to that inbox get blocked


#20

$50 to ship the thing back is pretty steep!