My DS Won't Update to RedCloud - Totally Stumped


#1

Have spent the last 2 hours trying to update my DS’s firmware to RedCloud.

I have done this many times in the past 4 firmware’s and am familiar with the upgrade process.

Tried on 4 different newly FAT32 formatted SD Cards, 1 8GB, 1 4BG and 2 1GBs… all the same result.

When turning on the unit with the SD Card properly inserted with the RedCloud files, instead of the light blinking to commence the update it just boots up like normal no matter what.

I’ve tried unplugging the powercord for 10 minutes, then holding the front button to reset the PSU inside while its off and winding down. Still nothing, when I flip the back switch on, just a normal bootup. Also tried inserting the SD Card while its still on before cycling the power and also inserting the SD Card after it’s off and no difference, doesn’t start loading the new firmware no matter what.

Can’t see what it could be other than some kind of defect that has maifested itself with the SD Card reader in the back of the DS :frowning:

Makes sense as I’ve had coverart issues. Could be that there is indeed an issue with the card slot?

Any help would be greatly appreciated.

Thanks in advance!

Emil S.
NJ, USA


#2

Just to make sure: did you use the OS’s eject function before removing the card from the computer each time? If your computer is caching writes to cards by default, then the eject is critical.

The DS may have a partial update from the first attempt at upgrading that’s keeping the subsequent upgrades from working. If so, install Torreys, Yale or some older release than the release you were on before trying to upgrade, then you probably can install Redcloud.


#3

And also, format the card using Windows, as formatting on a Mac seems to give some linux-based systems fits.


#4

@emilsejr,

Have you tried formatting the card as FAT16? If you have not, please do.

I don’t know if you are using a Mac, but here is something I wrote a while ago on how to format FAT16 with a Mac:

To format Fat16 on the Mac you will need to use the Terminal app.

Insert the card and from the command line type this:

diskutil list

Locate the “Identifier” for the card. In my case, it was “disk7”.

To format the card, it needs to be unmounted using “diskutil”. Here is the command:

diskutil unmountDisk disk7

You will get a message telling you if that was successful. If it is, here is the command to format the card Fat16 with the name “DSD”:

sudo newfs_msdos -F 16 -v DSD /dev/disk7

You will be asked to enter your superuser password. That is normally the password of the main account setup as an admin account.

I tested this with a 16GB card and it was formatted to a capacity of 2.15GB.


No More Firmware updates!
#5

I am on Windows 10., Have tried both FAT16 and FAT32 and always eject before removing… and tried Pikees, Torreys and Yale for the sake of seeing if there is partially loaded firmware as per Ted’s suggestion.

Still no dice :frowning:


#6

Don’t know if this helps or just confuses, but my Windows 10 laptop cannot even detect the PS Audio supplied Kingston 8Gb sd cards. But, if I put in a Sandisk 8Gb card the laptop sees it straight away. Maybe the card readers in PS Audio kit are sensitive to card manufacturer too.


#7

Could be.

I’m on a desktop and as noted in my opening post that I’ve tried different makes and sizes as well as quick formats and slow formats on all of them.


#8

Update!

I’ve FINALLY successfully upgraded the firmware to RedCloud.

Here’s what I did to finally have it perform the update.

  1. I inserted a Yale OS SD Card, DAC Made 2 fast blinks then turn on as normal, but still on Huron.

  2. When the DAC was on and booted up, I removed the Yale SD, Played some Test Tones. Then turned off the DAC with no SD Card.

  3. When off, I held the front button for 20 seconds, then turned the DAC on with NO SD card inserted (1st clean boot with no card inserted), played some test tones, then went into the maintenance screen, ran Test #1 and it passed and enabled debug and then turned it off.

  4. Unplugged the powercord and held front stby power button for 20 seconds when it was off.

  5. While it was off with power cord unplugged, I inserted the Red Cloud OS SD Card, and turned on the DAC.

  6. Voila! DAC turned on detecting the new OS on the SD Card and the PS Audio button began blinking for 1 minute then booted. And sure enough upon checking the Firmware. It said Red Cloud!

So it seems something was cached or older firmware was partially still on there as Ted suggested, but I also think this caused some sort of Reset of my SD Card reader on the DAC as I knew it wasn’t my SDs.

Hopefully this helps others that had a similar issue as I did.

Thanks for help gents!


#9

Also it would be nice if we could remotely and via the built in firmware downloader for the Bridge II if we could upgrade the DAC firmware via on the screen menu as with the Bridge II.

I think this would be a GREAT feature and could help mitigate potential issues, as well as make it easier for less technically proficcient owners upgrade and not have to worry about anything else. It’s also nice since it automatically checks and let’s you know when a new version is available if you toggle the settings.

Another suggestion I have is to sent a mass email to PS Audio owners if a firmware update is available for their Bridge or DAC for those of us that don’t check the forums very often. I just learned of the Red Cloud a few days ago as I had no idea. And had been on Huron still for months after Red Cloud was released in November as I have now learned.

As someone who owned a DS when it first came out then tried a few other DACs at and a good amount above the DS’ price. I came back to the DS a year ago due to missing its unmatched function and features than require 2 separate devices with other competitors as well its wonderful form and LCD display and USER upgradable semi-frequent firmware updates to make this thing sound better and better. Sound wise it’s the most natural sounding and versatile DAC I have owned compared to PS’ direct competitors products.

Thanks and keep up the great work Ted, Paul and team.