NPC Firmware fail & success


#1

This is my first Forum post - sorry it has to be about trouble, but I did achieve success after several hours of ‘dicking around.’

Yesterday I attempted to follow the “How to update firmware in the NPC” instructions at the PSAudio website. My NPC had the firmware ‘Main’ version 0.44; and, in order to use the “Vinyl Studio” (Alpine software) its forum advised to upgrade to version 0.52 in order to successfully be able to record DSD format.

The firmware Main 0.52 package at the Vinyl Studio contained one less file that the package at the PSAudio website. The added file in the PSAudio website package was “Loader.CFG.9999”. Otherwise the Vinyl Studio website and PSAudio website Main version 0.52 firmware upgrade packages appeared to have the same content. I had also acquired from the PSAudio website the Main version 0.48 firmware upgrade package.

Using a FAT32 formatted Sandisk 16G USB drive I had no luck initially. Following the “How to update firmware in the NPC” did not result in any firmware updating. I then re-formatted a ‘No Name’ 8G USB drive and transferred the Main version 0.48 file package to it. This USB had a ‘flashing light’ in it when it was in use. My intent was to ‘see’ if the NPC was accessing the USB drive at the time of the power switch turn-on.

This did not work either … becoming pissed, I then noticed the very small inset “Reset” button adjacent to the USB firmware update connector. Cycling through several sequences of:

  1. Power off; 2. Power on; 3. Followed by an immediate Reset button push

Finally loaded the Main version 0.48 firmware update package. Then I loaded the Main version 0.52 firmware update file package onto the NoName USB drive, erasing the old 0.48 files first.

At least four sequences of the ‘Power Off’, ‘Power On’, immediate ‘Reset’ button push were required before the 0.52 package was loaded after I changed to the Vinyl Studio 0.52 update file package (from its forum - software author).

Why does the PSAudio version 0.52 package have a “.9999” file type in it. Please note that I ended up erasing the PSAudio 0.52 update package and loading the Vinyl Studio 0.52 update package which does not have the “.9999” file in it. In terms of superstition, I must advise that the “.9999” Loader file in the PSAudio package seems to be ‘bad juju’ … but then again the whole NPC update process seems to be ‘bad juju.’

The “How to update firmware in the NPC” instructions at the PSAudio website says nothing about pushing the “Reset” button … and it seems like pushing the “Reset” button (as described above) is The Thing which made the update work. Unpleasantness all around.

John - Acoustic Line Source Research

p.s. the version 0.44 software worked with Sony Sound Forge Pro software to record PCM files before this firmware update.


#2

I will look into this. That is not the way it should work. What is the version of booloader on your NPC? It is on thew version screen.

Dennis


#3

Hello Dennis,

My apology for the delay in reply. I was having difficulty in finding my notes on the firmware update.

For completeness here is the sequence of reported NPC on-screen versions after the various updates:

Initial state ------------------------

VER USB 10

Main 0.44

CPLD 1.07

USB 00.15

Boot 01.09

Update 1 ----------------------------

VER USB 10

Main 0.48

CPLD 1.08

USB 00.15

Boot 1.10

Update 2 -----------------------------

VER USB 00

Main 0.52

CPLD 1.08

USB 00.16

Boot 1.10


Note the “VER” change to USB 00 from USB 10 in the final “Main 0.52” update. What does that mean?

Can you comment on the “loader … 9999” file in the PSAudio download - which does not appear in the Vinyl Studio forum (Alpine) version of the update download? Remember I had to ultimate use the Vinyl Studio update, since the PSAudio 0.52 update wasn’t working (was it the *.9999 file causing the problem?).

I have been unable to test my NPC since the firmware upgrade due to a major system disassembly for major upgrades (which the NPC firmware upgrade is part of).

I reemphasize that the update would not take place on both the 0.48 and 0.52 versions without pressing the “Reset” button numerous times.

John


#4

Thank you for the information. I will try to reproduce and fix the issues you report.

Dennis


#5
Dennis Kerrisk said Thank you for the information. I will try to reproduce and fix the issues you report.

Dennis


Can you also look into dating your upgrade firmware? As in, date of release next to the version on the web site and maybe a link to the “whats new” associated with the upgrade? I own a P5 and NPC and have to say it is a pain trying to figure out what is new and what the firmware does. I’m guessing its buried in the forums but why not just put this info all in one place?

#6

I’ll talk to the people in charge of the web site and see if we can get them to implement this.

Dennis


#7

I got my NPC yesterday, it is running at firmware 0.44.

So I downloaded the latest update from this site, unzipped it into a 4Gb USB thumb. Power off the NPC, plugged in the 4Gb USB thumb at the back of NPC, power on NPC, I waited for 15 minutes still nothing happen, I check the display it still shows firmware 0.44.

Then I tried another two different USB thumb (1 x 4Gb, 1 x 1Gb), tried to format the USB thumb at FAT and at FAT32. All resulted the same, and the NPC is still running at 0.44.

In between, I did press the reset button before power on the NPC hoping it can trigger the upgrade but still not working.

The NPC @0.44 works, but I think it will work better at the latest firmware. Please advise how can I upgrade the firmware.

Thank you.

Bryan


#8

Try this update, it is a force update, and should work for you:

http://updates.psaudio.com/dak/11-066-11-X-FMC-15-9999.zip

Dennis


#9

One more question:What is the version of bootloader? If it is not 1.10 then we will need to get you the bootloader upgrade.

Dennis


#10

Thanks Dennis,

Need to check the version of the bootloader, but I guess it still remains at the factory original considering my firmware is still 0.44


#11

Try this one:

http://updates.psaudio.com/dak/11-066-11-X-FMC-10.zip

it will upgrade the bootloader and update to version 48. Once you have done this one, then update to the latest.

Dennis


#12

thanks.

I copied from the display as below before doing any of your suggestion:-

Main: 00.44

CPLD: 01.07

USB: 00.15

Boot: 01.09

USB: 10


#13

You definitly need the new bootloader.

Dennis


#14

Thanks Dennis,

Successfully forced it to update by your special tool, and after that do the normal update using download from this website.

Now the display shows:-

Main: 00.48

CPLD: 01.08

USB: 00.15

Boot: 01.10

USB: 10

Thank you very much.

Bryankiss


#15

For unknown reason, further update won’t get any further after I tried several times for the latest 00.54 firmware.

The display still shows the same:-

Main: 00.48
CPLD: 01.08
USB: 00.15
Boot: 01.10
USB: 10

Any idea?

Bryan


#16

Hello Bryan. I must say that I also had problems to update my NPC to version .54 (from .52). I was trying it with a 4Gb and 8Gb Patriot USB memory stick. No success. Neither with John’s method. My very first USB stick, a 500Mb no name thingy did the trick. Just to mention.

Good luck!

Mario


#17

Thanks Holzohr, I already used a very old 1G Scandisk thumb drive. I used this same thumb drive plus the special file by Dennis that allowed me updated to 00.48.

So I hope Dennis can make another special version of updated files so that I can reach 00.54

Bryan