NPC not seen as recording device


#1

I want to digitize some tapes. I went through the front panel settings, in particular enabling USB and switching from Phono to Analog inputs. The PSA Windows driver is installed (latest version. 1.6.1); if I go to Device Manager, it shows up and if I open it I see both the DS DAC and the NPC listed. I use Windows 10 and will record to PCM, not DSD (this is also set correctly on the front panel).

But in the Sound section of Control Panel, under the Recording tab, it says that there are no recording devices installed. This is consistent with what happens in Vinyl Studio. I go to Check Level and it says that there is no default recording device. I am able to select the ASIO control panel and the PS Audio driver within it, but then Vinyl Studio says that the NPC cannot record (or perhaps is not connected – but that shouldn’t be the issue since it’s visible in Device Manager).

Anyone know what I am doing wrong? I used to be able to record with the NPC + Vinyl Studio on the same Windows computer, but it’s been a year or more since I did so. One thing that may or may not be relevant: after I reboot the computer, the NPC is not visible in Device Manager, but if I unplug/replug the USB cable it shows up.


#2

Update: tried again this morning. NPC now not seen at all, despite reconnecting the USB cable. I discovered that in Device Manager I can choose View/Show Hidden Devices. If I do this, I see two instances of the NPC (on different hubs/ports), both of which are said to be unconnected even though the NPC is plugged in. Scanning for hardware changes does nothing.


#3

Have you tried uninstalling these devices in device manager and rebooting? The system then should find the NPC in its appropriate location.


#4

Tried this. The NPC is now again visible in Device Manager as installed and functioning properly, but there is still no recording device installed according to the Sound applet.

I decided to uninstall and reinstall everything, so I deleted first the DS DAC and then the NPC from Device Manager, with the latter checking the option to uninstall the driver; then rebooted.

After rebooting, tried to reinstall the driver but got a message that this was already installed. Device Manager now shows the DSD but not the NPC (unplugging/replugging will probably fix that). I’m guessing that during the reboot Windows recognized the DSD and so automatically reinstalled the driver (?).

So back to the original question of how to get Windows to recognize the NPC as a recording device. Why does Windows have to be so damn finicky about drivers? For a year I have had this project in the back of my mind. I finally got out an old tape deck, cleaned the heads, located the tapes and now can’t record.pulling-hair_gif


#5

Argh. I wish I had another idea. Computers can be silly finicky.


#6

You can follow the reinstall USB “How To”: http://www.psaudio.com/ps_how/how-to-fix-usb-connectivity-issues-with-dacs/

There are also some other USB How To’s that might be helpful.

If there isn’t any uninstall entry for the USB drivers in the normal Windows Uninstall you can use the device manager (after showing hidden devices) to uninstall ALL of the devices from PS audio (probably two entries / PS Audio unit, maybe more.)


#7

Thank you, Ted. I was trying to uninstall from Device Manager rather than Programs and Features. I’ll try again following the how-to that you linked.

What if you have more than one PSA device (NPC and DS DAC, in my case). Do you plug them both in at the same time when prompted, or is there a separate install process for the second one?

Note to PSA tech support: yesterday I read this how-to, which says connect the device before installing the driver. That’s the opposite of what the other one says, and I’m guessing that holding off until prompted to connect is better since I haven’t gotten results with connecting first.


#8

Yep, when is says power off the PS Audio device, power all PS Audio devices off. When you uninstall you want to uninstall over and over till no PS Audio item shows up. But later when you re-install do them one at a time. Tho in any given case you may be able to skip a step or two, there are cases that require each and every step in order.


#9

I followed the steps in the How-To that Ted linked. This resulted in a much more thorough process. I did not try to reinstall the DS DAC, just the NPC. Everything seemed to go correctly.

But there is still no recording device shown in the Sound applet and Vinyl Studio is still protesting that the NPC cannot record and says I should choose a different device. (NPC looks correct in Device Manager.)

I did a little internet searching and found a few situations where Device Manager and Sound disagree, with the former saying that speakers were installed while the latter does not see them. So it is clearly possible for Windows to get confused about such things. Unfortunately none of these pages guided me to a solution.

I am starting to get seriously annoyed.