NuWave DSD audio stutters [Solved]


#1

Hi community, Im experiencing a very annoying issue, I hope someone can give me a hint on how to solve this:

I just bought a NewWave DSD DAC, installed it on Win10.

The problem is that while connected to USB, audio stutters constantly, no matter the program, JRiver, Youtube, WMP.

Optical conection has no issues at all.
Already tried reinstalling drivers to no avail.

I’m totally lost here, any help would be much appreciated.


#2

I assume you’ve downloaded and installed the PS Audio driver. Is your USB cable of normal length? (eg under 6 feet). I suspect it’s something in the computer setup but I am not a Windows guy. If no one else has a suggestion, call Jeremy in customer service on Monday. He’s really good with such things. We’ll get you going.


#3
dominewolf said

Hi community, Im experiencing a very annoying issue, I hope someone can give me a hint on how to solve this:
I just bought a NewWave DSD DAC, installed it on Win10.

The problem is that while connected to USB, audio stutters constantly, no matter the program, JRiver, Youtube, WMP.

Optical conection has no issues at all.
Already tried reinstalling drivers to no avail.

I’m totally lost here, any help would be much appreciated.


Hi dominewolf,

Please give us a call or email when you can.

We’re happy to get your system up and running.

720.406.8946 EXT 2

service@psaudio.com

  • Jeremy

#4

Solved! Changed the USB cable for a better one and everything is working fine now.

Should have taken into account your advice in the product guide, to use a very good quality USB cable.

Thank you very much Paul and Jeremy for your quick response.

Is there any way to change the title or status of the thread to solved?


#5

Excellent news!

i changed the topic name. Great idea to indicate that the issue was solved. It may help people looking for a solution to the same or a related problem.