Nuwave phono firmware update


#1

I’m new to PS Audio and recently purchased a NuWave phono to record some vinyl. I read the forums for updating the firmware from 0.45. I downloaded, unzipped 0.55 and copied the files to a formatted 64gb USB stick. Turned the Phono off, inserted the USB stick and turned the phono on. The blue light flashes for a minute or so then it reboots. From the screen im not sure if anything has happened. attached is a shot of the screen after.

Any help would be appreciated. Thanks, George


#2

I’ve got a hunch the update didn’t stick because the numbers on the NPC status window there don’t seem to correlate with the file numbers in the update package.

I’m curious why there is a 9999 loader.cfg file in the 0.55 update package, I thought the 9999 is a forced version which PS Audio doesn’t make available for public download.


#3

You’re correct and I don’t know why that should be out in the wild. There’s a lot of holdover of bad practices before Matt joined the team and installed version control and standards for the team.


#4

Should I try the version before .55?


#5

I suggest you pause for a moment and wait for PS Audio to check the files in the update package. As Paul mentioned, that force load version should not have been there. You need to be cautious and know exactly what you’re doing if there is a force load file in an update package.


#6

Good idea


#7

I just downloaded the .55 update and unzipped it to find this:


#8

These are perfectly fine to use just DO NOT try and load this into another PS Audio product not the one it was intended for. The 9999 code is what we all use internally so it’s just fine. The only danger is putting it in the wrong kind of PS Audio device like a DS or Power Plant.


#9

Thanks, any advice on how I can’t get it to load?


#10

Same here.


#11

I would. My NPC was delivered with .54 loaded i never had any issues with it. I updated to .55 and suddenly I could not adjust any settings as the display would shut off within 2 seconds of hitting a button. I took it back to .54 and I am ok again!


#12

Any comment on how I can update the firmaware?


#13

You can download the latest firmware from the Resources page. unzip it and copy it to a thumb drive. power off the NPC. insert the drive into the vertical USB slot on the back of the NPC. Power on the NPC. IT will take a while to do the update. After it does it is still not finished. be patient it goes through some steps before the normal operation screen shows up. After that does power off the NPC and remove the jump drive! There is a video that explains the update procedure.


#14

I have now reloaded Version .55 and so far it has been running ok.


#15

I tried that then started this thread for help. I’ll try again and report back


#16

What happened when you tried the update?


#17

It went through about 3mins of PS Audio badge flashing blue then rebooted to 0.45, as per orig screenshot. I downloaded a fresh today version of 0.55 and tried again with same results

I did the USB 2.0 update and it worked.


#18

Are you waiting a significant amount of time after the flashing stops. It seems that the first step it downloads the data into the NPC and than after it reboots it takes a while for the actual update. I know the first time I tried to update I thought it was not successful. The next attempt I gave it time and than it did succeed. My NPC came with .54 so it may have some difference from yours due to age difference. If you try again and give it allot of time and you still do not succeed I would contact PS Audio tech support and see if they have any other suggestions for you to try.


#19

I left it 10 mins ish. I’ll try again and leave it for an hour or so


#20

The 10 minutes should have covered it. I hope you get the issue resolved.