Phono Converter won't switch to analog inputs


#1

NuWave Phono Converter won’t switch to analog inputs even when the front panel says “Analog.”

Is there some magic I’m missing? I’ve power cycled the unit a few times.

I can hear/capture vinyl from the phono inputs just fine… but I hear the signal from the phono inputs even if I switch to analog.

Is that just broken and needs repaired?

BG


#2

Is the A/D mode set to PCM or DSD? Shouldn’t matter if you have a DirectStream, though.


#3
radioclash said Is the A/D mode set to PCM or DSD? Shouldn't matter if you have a DirectStream, though.
Not sure if I do? How can I tell?

And what difference would the A/D mode setting make for which inputs are selected?


#4

The A/D shouldn’t matter. The manual says the analog input is limited to 3V rms. No idea what happens if you exceed that. There is a factory reset button on the rear. You might give that a try just in case. Write down your phono settings because you’ll need to re-enter them. I’ve only used the phono input so I don’t know what else to suggest.


#5

I would guess you should contact us so we can have a look at the unit. Sorry for the problem.


#6

I have the answer from support:

“The NPC will only output the Phono input signal from the analog outputs.
Both the analog input and phono input signals are output from the Digital outputs. You may switch between the two from the front panel.”

I just confirmed that to be correct. That’s a real plot twist there… you guys should probably put that on page 1 of the manual in 48 point font.

You know, in case some bonehead connects a tape deck and expects analog output!


#7

Oh, sorry, I missed that in the beginning of this thread. It is, actually, in the manual, though you’re right, it could have been plainer. We just assumed no one would want to have analog in and out without doing anything. The idea behind the analog inputs is to be able to digitize the signal. Which is really the only function it has.


#8

Yes I had misread this as well. I have a tape deck connected too, with A/D set to DSD and output to my DS. Works really well.