Please help with upgrade advice


#1

Please could someone help me.
I have a directstream DAC running Yale, Bootloader 1.13, Firmware 1.6.4, Bridge 0.0.0 FPGA 0.91 USB 00.33 Rev 0126

I am trying to upgrade to the latest firmware and also need to run Roon. I am running Roon now via USB on my MacMini but have a Synology Diskstation and wanted to run it direct. I am not sure exactly which files to use from the downloads. I have read and tried a few but when I power the device it does not see the USB or a SD card. I have tried both. I have followed all the instruction so any advice would be very much welcome.

Kind Regards

Howard
.


#2

If you have a DSD Sr then you need to use the SD card. You probably want the “Redcloud DirectStream DAC” download. Put all of the files in from the downloaded .zip file on the root of an SD card.
There are some relevant "How To"s http://www.psaudio.com/ps_how/how-to-update-with-an-sd-card/ and http://www.psaudio.com/ps_how/upgrade-directstream-operating-system/
If you have any problems ask here again and/or call or email PS Audio support.


#3

Hey Ted
Thank you very much for getting back to me so quickly, I managed to upgrade to RedCloud and I connect to the internet as I am getting an IP address back which I can ping form my Mac terminal, so I know the Directstream is connected to the net.
My Bridge version is still 1.2.1. which I know is very old but it does not give me the option to update it and says it up to date.
If I run Roon and ask it to scan for an end point and give it the Bridge IP address I get nothing back, not sure if its because of the old Bridge firmware? I did try the Bridge 2.1.5 on the downloads but no success? and help would be great.

Howard


#4

I’m not a bridge user, but I think that you do need a more recent bridge version for Roon - if I remember posts correctly you might want to make sure that Roon (JRiver or whatever you might use to talk to the bridge) isn’t running, turn the DS off (with the back switch) for a little, turn it on and wait for, say around 5 or 10 minutes to see if it then says there’s an update available.
Being able to ping the DS doesn’t necessarily mean it can connect to the net outside your house. Some have recommended that you turn off all of the DS, the device your control point software is running on, your router and any network switches you have between the router and the DS and the DS and the device you run your controller software on. I think the best power up sequence is router, switch, your computer, then the DS.
Hopefully someone that knows about the bridge and Roon will see your question. The new site has better search that might help find more things to try.


#5

Kasmenu,
I suggest utilizing the “DirectStream Bridge Rescue” located here: http://www.psaudio.com/support/downloads/

Once you run this utility, boot the DSD back up and see if your Bridge then shows the option to update to 3.5.1. My guess is your firmware is too old and is causing issues. The Rescue should help to get you back on track.


#6

Maybe call us on Monday.

If you need a tutorial on getting a clean SD card: http://www.psaudio.com/ps_how/how-to-format-an-sd-card/

If it’s the Bridge you need to update go here: http://www.psaudio.com/ps_how/how-to-update-bridge-ii/

There are lots of How To’s on our website: http://www.psaudio.com/ps_how/


#7

Hi Paul,

Thank you very much for the reply, Yip I understand about running Roon via Ethernet and have it plugged into my router, I am getting an IP address back so I know its connected and the network icon is Green. I also upgraded the firmware to Redcloud and if I check the info panel its says its running Redcloud, What I cant it it to do is update the Bridge II firmware, its still version 1.2.1. The unit says I have the latest firmware which I know is not correct.

I can call as you suggested but I am based in Australia.

Regards

Howard


#8

I have the same issue same dac , same version. I can’t upgrade the dac and don’t know which FW to use , which is latest


#9

You guys could try using the mcontrolHD iOS or Android app to connect to the Bridge II and see if you upgrade it.


#10

OK, I fix it . The problem was the SD card was 64 Gb , in instruction is written max 32 . Then I used Samsung 2GB SD card and loaded the latest RedCloud FW. I thought that RedCloud is a DAC model and was a little bit confused. After the update , connect the DAC to network -> Bridge II -> there was a small icon UPDATE ! -> pressed and voala :slight_smile:


#11

Email service@psaudio.com and they’ll help you.


#12

Thanks Paul have mailed them already with a link to this thread.
To answer Teo, I also used a smaller 8gb SD card and the firmware updated but there is no option to update the Bridge firmware so I am still stuck on the old one and hence can’t get Roon running as an end Point.
I will post my solution from the psaustio support team here for others to gain some insight if experiencing the same issue