Red Cloud - USB from Roon Rock - intermittent issues [Solved]


#1

Hello,

As I mentioned on another thread, I am having ongoing issues with Redcloud.

I have a DirectStream Junior. I am feeding it from a Roon Rock server (NUC) either via Bridge (ethernet) or by USB direct from the Roon Rock into the USB input of the DSJ. Playing to USB is giving me 3 issues:

  1. Roon looses the server quite often. This requires me to a hard reboot of the DSJ (power cycle). I am not getting these issues when I stream to the DSJ over ethernet using Bridge.

  2. Every once in a while, the USB only comes out of the right channel. If I switch to Bridge then all is fine so there are no issues with my other gear. I do the hard reboot of the DSJ (again!) and it will usually fix the issue.

  3. USB occasionally starts skipping tracks.A whole album will skip through with each song appearing for a few seconds. I can play the same song using USB into the DSJ using Roon at other times so there is no issue with the tracks / files themselves. The files are stored on a hard drive that is irectly connected to the Roon Rock so there would be no network issues that could come into play. Again, a hard reboot will usually fix this. Until the next time.

I have given up using USB at this point. Thankfully Bridge is acceptable (apart from tiny drop outs about once every 1-2 minutes) but I thinking that the dropouts are related to my network setup.

I have tried the following:

  • Rolled back the Firmware to Huron and then went back to Red Cloud.

  • Reinstalled Roon Rock OS.

  • Made sure Roon is all up to date.

  • Adjusted about every setting that I could think in Roon such latency settings, clock priority, sampling rate, DOP etc.

As I said, a power cycle will mostly fix the issue for the time being though with the USB through one channel that can often require multiple reboots.

So is this a Roon issue (last update was prior to Red Cloud I think) or a DSJ firmware error or both. Huron did not have these issues so that’s the only factor that has changed in my setup.


#2

As I stated earlier the USB skipping can’t be anything to do with the software release. The USB code itself is identical between Redcloud and Huron. The DAC doesn’t know anything about file boundaries. Nor can USB affect a connection to Roon - Other inputs than the Bridge know nothing nor provide anything for a downstream network connection. Given those two it would be reasonable to assume the right channel only on USB problem is ahead of the DAC too since no one else has reported anything like that and indeed the work done on the FPGA for this release is all channel independent and the FPGA doesn’t know the difference between the USB input, the Bridge input or the I2S over HDMI input - they all use identical code to receive the I2S.

Still, do you have the USB problems with the Bridge physically disconnected? If so it might have something to do with the Bridge software release and something there is annoying something upstream (tho I can’t guess how). I don’t remember you mentioning reverting the Bridge code and reloading it (but I could easily overlooked that in your other posts.)

Similarly, just for debugging sake and if you aren’t already, could you try a cheap USB certified cable from Staples, “Radio Shack”, etc. If the USB cable you have does anything non-standard with the 5V it could be confusing anything in the USB system upstream (are the drives that your music are on USB?) The power cycle things you mention are often a problem if the USB 5V isn’t connected continuously. For that matter, if your USB cable is too long (about 15’) things can go south quickly depending on the specific hardware in your system.


#3

Ted,

Yes, I did roll back to Huron. I mentioned it in an earlier thread in passing. I was having massive issues with the sound and I think I rolled back at your recommendation (or a general bit of advice that you gave at that time in the thread). And on reloading the Red Cloud firmware it did get rid of the major issues but then these new ones popped up.

I’ll try pulling out the ethernet cable tomorrow (assuming that’s what you meant about disconnecting the Bridge). And I do have a number of compliant cables that I’ll try it with also i.e a “hifi” cables and a few boggo computer PC cables.

The music is on a hard drive that is connected to the same NUC so that might be causing an issue - it’s just odd that this would be an issue when using Red Cloud.

Mark


#4

I didn’t ask about rolling back to Huron from Redcloud - I asked about rolling back the Bridge II software.

As I mentioned the USB software is the same in Huron as Redcloud so something else changed, and the Bridge software seems like a (remote) possibility. I don’t really have any idea how the USB would be affected by the bridge software: except if the source were paying attention to the Bridge while playing to USB there could be an interaction. In the DS, tho the Bridge software interacts with the UI, the FPGA plays just fine even if the UI has crashed so if there’s an interaction between the Bridge and USB it’s probably upstream.

Since I’ve seen all of your symptoms with USB cables that lift the 5V line and most of them with really long USB cables, I thought I’d toss that out as a possibility too.


#5

Ted,

Sorry, I had a dumb moment. For some reason I thought that the Bridge software is incorporated into the DSJ Red Cloud firmware! OK, so I’ve just read up on the method to update Bridge in the DSJ and I’ll do that tomorrow. Again, I’ll try a few of my USB cables to make sure nothing funky is happening on that side of things.
Thanks for all your help.

Mark


#6

Ted,

I did the Bridge update as you pointed out. Rebooted and all is perfect now.

Thanks for your help and patience.

I am enjoying the subtle differences between USB and Bridge playback from my Roon Rock. Neither is “wrong” or “right” of course but there are subtle differences. 2 DAC’s in 1!!!


#7

P.S. As a suggestion, if this does not exist already, is there a way to incorporate a “solution accepted” button that the OP can press when a solution has been found in this forum? It doesn’t need to close the thread to further responses though. I have seen this on software support forums and it’s useful to people seeking help plus it conceivably will reduce the amount of work for you guys in that people seeking solutions will (hopefully!) see the solution before posting. Just a thought.


#8

That’s great, I didn’t know where we were going to go after that :slight_smile:

You can PM Elk or another administrator and ask them to edit the title or description marking something solved. I’ll mark this one.


#9

Ted,

I can also report, much to my satisfaction that over the entire period of the day, after I updated the Bridge, neither the USB or the Bridge streaming suffered a single stutter or drop out. Problem solved! Not sure what happened there but I’m not looking a gift horse in the mouth.This and the new sound from Redcloud is a really nice Christmas present.

Mark


#10
scumbag said

P.S. As a suggestion, if this does not exist already, is there a way to incorporate a “solution accepted” button that the OP can press when a solution has been found in this forum?

Excellent idea! And thanks to Ted for marking this one solved.

We do not have a solved button for the OP to press, but marking the thread does the same thing.