"Sandy" sound from PWD (both Bridge and USB)


#1

Hi all. I have the latest and greatest (?) upgrades:

Bridge Version:0.2.15
DAC Version Mark II:2.4.4
CPLD:1.16
USB:1.03
Flash:AT49BV320
LCD:Epson

I play ordinary CD rip (16/44.1). Some tracks sound like my headphones are full of sand. It sounds like tiny sand particles bump into membranes producing faint cracks. When I play the same track on my Mackbook with the same headphones it sounds perfectly clean and smooth. The same “sandy” sound happens when I play it on PWD over Bridge and over USB, no difference at all. I did try a lot of tests with different tracks. Some tracks are affected more, some less. In rare cases I don’t hear any problems at all. Any clues, folks? Is my PWD defective? Any way to reset it back to factory defaults? Thank you.


#2

That’s weird. What program are you using to play the music with to the Bridge?doh_gif


#3

I tried two: JRiver 18 under Windows (-> Bridge) and iTunes under MacOS 10.9.2 (-> USB). Same behavior.


#4

I’ve never encountered a “sandy” sound so my best guess is a bad connection somewhere or a botched firmware update.

When did this start and had anything changed? Like updating to 2.4.4 or the bridge 2.15?

You could try dropping back to an earlier version of PWD firmware, see if it improves, and then back to a fresh install of 2.4.4 if you wish.


#5

Thank you. I tried to downgrade - no changes. Then I tried Foobar… And it did work! Seems like JRiver is messing up somehow. Yes, I tried all play modes out there with and without decoding. No way. Foobar is not so user friendly though but it plays right.


#6

have you tried a reinstall of JRMC?

It should work fine. Just set the upgrades to “latest stable” as the latest Mac version has hiccups.