Stereo Channels reversed when playing DSD over PCM


#1

Hello

I am using a PS Audio Nuwave DSD DAC with JRiver MC21 for Windows 10 (version just updated). My PC is connected to the DAC via USB cable. I recently purchased 2xHD’s “Audiophile Hi-Res System Test - Great Sampling Tracks Included” recording in 2xDSD format from HD Tracks.

I was playing this new download and noticed during the test tracks that the left and right channels are reversed. I was wondering if other NuWave DSD owners are experiencing this as well or if the problem is with JRiver MC.

If this is a problem with the NuWave DSD DAC DoP input, can we expect a fix?

Thanks for your help.

I’ve posted the issue on JRiver forum.

To troubleshoot I visited the HD Tracks website and played the samples of the test recordings and the proper channels played. This bypassed JRiver MC21. Next I downloaded some *.wav test files for left, right, both channels and played them using JRMC21. When I set the JRMC21 DSP output Encoding to “none” the files played on the correct channels. When I set the DSP output Encoding to either 2xDSD or DSD in DoP format, the channels were reversed. It did not matter whether the DSP Encoding was set to “None” or “2xDSD in DoP format” or “DSD in DoP format” when playing the 2xHD Double DSD test tracks. The right and left channels played on the opposite channel. This was the same for the test tracks where the recordings played bells off center to the left and to the right.


#2

I was able to resolve this matter. I reached out to the JRiver interact forum and got some help with settings and using tools to correct the DoP input to the DAC. I had to adjust settings in JRiver MC21.

One issue was I had Bitstreaming (DSD) enabled, which I had to set to “none” to use DSP studio. I used the Parametric Equalizer in DSP studio to run tests to perform muting channels to discover that the left and right channels were reversed when playing back via DoP. If I disabled DoP then the channels worked properly. Setting Output encoding to “none” causes DSD files to convert on the fly to 176,400 PCM.

To address the original problem to fix left and right channel transposition, I set Output encoding to 2xDSD in DoP format. I went back to DSP studio and removed the mute filter used to conduct channel testing, and added a mix filter. I set the source to “left” and destination to “right”. I selected for mode “Swap (swap source and destination)”. This was the setting I saved that corrected left and right channel playback.

I did some further experimenting and found if I added a second filter set to swap the right source to left destination, the problem returned (stereo channels transposed). I further found if I used one filter to swap the right source to left destination, this also corrected the problem.

I’m still not sure if this is an issue with the USB DoP input on my NuWave DSD DAC. Going forward, if I for some reason migrate out of JRiver Music Center to different software, I’ll have to make sure the software has DoP adjustments for left and right channel settings. If this comes up again I should be able to correct.

I don’t have anything to use the I2S inputs. I’m not sure if there’s problems there as I don’t have anything to test them.


#3

I am using Roon, and the same problem occurs during DSD Upsampling

playback (DoP). Is there a problem with Nuwave DSD?


#4

Hi there

Yeah, I found out that the DoP channel swap on the USB device was a known defect on certain NuWave DSD DACs. I emailed PS Audio about it and they told me about it. I registered both DACs so they are still under warranty. They had me verify my serial numbers and I received RMA numbers. I shipped the DACs back to them. The firmware updates to correct were done at n/c. I was out the insured shipping costs. I shipped from Seattle. It took about a 2 week turnaround. Jeremy Bretey over there at PS Audio helped me out. happy-048_gif Now my Nuwave DSDs play properly.

The fix I was using above, to use a parametric eq filter in JRiver MC21 to swap channels, worked until I purchased some DSD downloads with soft passages. The soft passages would get skipped over. When I defeated the filter by enabling bitstreaming - DSD, the skipping went away but the channels were reversed.

Hope this helps. Good luck ucchi