Stumped, all of the sudden no USB connection (DirectStream DAC)


#1

2 day’s ago the DS DSD was working fine on USB. Nothing changed, nothing had been disconnected or connected. The radio stream buffered. I went later to restart the radio stream and USB error. The PSA USB driver says device not present, please replug device etc. I have ran 3 different cables directly to the PC to troubleshoot to no avail. The interesting thing is every time any installer is opened including PSA USB Windows warns about installing on UAC. Now, the PSA USB driver only does not warn and goes right to install. Do not know if I just used it a lot so thought is safe. Or I have a driver problem. Something is wrong and I am almost certain it is not hardware. Different cables on different ports at the PC. It did install once upon multiple attempts but crashed. Perhaps I need to clean out the driver. Or reset DS. Don’t know either. All other inputs work fine. I believe something got corrupt. Since it happened without my touching anything,

I am very sorry I have had so many problems.

Thank you,
Todd


#2

Well, I just realized my printer has USB error as well. Will not print. Not sure what this is. If it is the PSA driver or something else. Really do not want to clean install! I certainly do not expect you to troubleshoot the printer. However, most likely the same issue is causing certain USB devices not to be recognized. I do not know if it has to do with PSA driver/DS or something else. In which case I understand I am fully on my own with this issue.

Thanks,
Todd


#3

Sorry to bother you. Reset unit, fixed. I hope this thing is not really buggy. A little touchy I don’t mind. See I had the wrong idea. Thought it was the PC end. Printer was an entirely different issue. Thank you


#4

I have had the DSJ lose the USB connection lately several times. Seems to just drop it, and it doesn’t appear as a source in Roon. I’ll be playing something, and next time I try to play something, the USB is gone. It could definitely be (and most likely is) something upstream of the DSJ, but this hadn’t happened before the past few months. I’m not saying it is Redcloud or the DS; I do have a new ethernet cable, and 90+% of the time, it’s wires. It’s a Starlight CAT8, which doesn’t fit quite the same as a CAT5. But I thought I would mention it, now that you do.

I’ll switch temporarily to Bridge and eventually will get it back, by rebooting the chain, unplugging/replugging or whathaveyou. But odd.


#5

It died :frowning_face: I am waiting for CS to return call. I don’t mean USB. It no longer powers on.


#6

That stinks. It’s possible that static electricity demons have invaded the unit via the USB cable. You might try completely unplugging the DS (including all power, network, and IC cables) and let it sit at overnight and see if the demons wander off by morning. It won’t hurt to try.
Good luck.


#7

Hi 2chan4ever,

Sorry to hear this!
The DSJ is equipped with a fuse on the rear panel.
There is a silk screen showing the fuse values.
I advise that you please unplug the unit from AC power.
Then remove the fuse from the rear and test it for continuity.
If the fuse is blown I am more than happy to mail you another at no charge.
Reach out to me directly at service@psaudio.com and I’ll get you going.

Thanks,

  • Jeremy

#8

Thank you. Got power, and music! Looks like some bad logic? The screen is upside down and completely frozen. Less than 90 days old. TJ tried everything he could think of. I forced reload 3 times, pressed other areas, cycled power, unhooked everything,. Not recognizing calibration, any press not registered again and again. If you can think of anything else I would be very grateful. Otherwise, TJ said send it back. Or try Peanut_Butter’ idea? He will charge me for one the same day and credit me upon it’s return. Or at least that is what I understood from him. I held out on the RMA hoping perhaps you or MR. Smith has any way I can fix it without opening it. I will wait to see if you can help hopefully or ship it to you tomorrow afternoon. Thank you, Todd


#9

Hi Jeremy, what’s the fuse size on the DSJ? Thx.


#10

Mine is obviously not the fuse. I see a lot of frozen screen issues on it. There must be an in place fix? I am not comfortable to open it though. It is in a suspension rack. Take me an hour to remove it for RMA. I hope MR. smith is not tired of me yet and will try to help. Or Jeremy probably knows. One other strange thing. If I turn the rear rocker from off to on all the way it turns off again. I just have to kind of flick it. Is that normal? Did I get a dud? My luck. After I waited to burn it in and secured in rack. I seriously hope they can have me get it working. Remote works fine just no touch response. Afraid to press to hard. It is no big deal because I have it dimmed anyways but if I ever need to access the menu… Still, it should be in working condition in less than 90 day’s. Just hope I do not have to send it back.


#11

Hi a25105,

The DSJ uses the same fuse across all voltage types:

1Amp, 5 x 20mm, Slow Blow

If you ever need one just let us know at service@psaudio.com and we’ll get one out to you right away.
Thanks,

  • Jeremy

#12

Hi 2chan4ever,

I assisted TJ with your service call and am so very sorry that you are having this trouble.
It is perplexing that the screen calibration tutorial did not solve the issue.
I’m concerned about your screen having trouble accepting touch inputs.
The best advice we have would be to send it in so we can have a look and get that darn screen working as it should.
I understand that your system is really important to you so I will be happy to assist in getting the service taken care of as quickly as possible.

Feel free to reach out to me at service@psaudio.com and I’ll get that DAC repaired and back to you right away.

Thanks,

  • Jeremy

#13

You can call me Todd. I want to leave it off for 24 hours, just shut off 3 hours ago. See if that works with any luck. This, along with the print server not functioning seemed to have occurred after I installed a Wrong driver for another USB device. As mentioned first it was dead, so I made some lead way already. It is up and playing but screen simply does not respond. If forced into calibration mode it still just does not respond to the 1,2,3,4. I touched like 50 times on just “1” and then the others but nothing. Let’s just leave it off and see what can happen. Some Eprom or NVM in there could take much more than a minute to dissipate of it’s energy. I kind of understand how the screen is driven so hopefully this works. I did read of numerous other freezes but they were resolved. If I have to send it so be it. The thing is I am elderly, disabled and it is my only entertainment. So TJ had said if I understood correctly after I provide the serial # he will ship a new one that day. Upon receipt of my unit he will credit me the $6,000 “security deposit” I had just given. If it does have to go back is that okay? It is of course in new condition being less than 90 days old save for the non functioning screen. So I imagine you can still sell it if you wish. Since you would not simply be repairing mine. That would drastically cut down the days I do not have it. I understand I am asking more than I deserve but given the circumstances I mentioned plus being nearly new I was hoping you could accommodate this as TJ had mentioned. Or any other way it can get back to me in less than 5 days. I would greatly appreciate that. Hopefully though it resolves by tomorrow being unplugged. Otherwise if there is any other operation I can perform myself you can think of that would be most preferable. I would be elated if MR. Smith has any ideas as well. Since it is his “Baby” Thank you, Todd


#14

Thank you!


#15

I just wanted to point out that this had nothing to do with a driver conflict as I had thought. That was a coincidence. Since I did in fact use the correct driver for the other device. I did not realize this until just now. Since Windows automatically installs the same driver for that device. Printer is working fine. DS is present in Control panel and producing proper audio. The screen is simply and completely frozen. I tried everything that is known to unfreeze it to no avail. It looks like this needs to be serviced or hopefully replaced. I sent an Email to TJ Friday night. I hope this can be rectified to my satisfaction since TJ had agreed with my idea of remedy. Please contact me Monday morning or as soon as possible.

It is not a big deal as the DAC functions for it’s intended purpose and display is on dim anyhow. However I feel I should have a fully functional unit in less than 3 Months of ownership. Certainly if I ever decided to sell/trade the device. Thank you, Todd


#16

You are certainly entitled to a fully functional unit and PS Audio will make sure you get one, one way or the other.


#17

Yes, without question we will make sure the customer is handled well and with courtesy and generosity.


#18

I know there is no problem with PSA. Like Cardas and Audioquest to name a couple other companies. Some people are worth their word and that is why I have been loyal to those people for years. I am not worried they fix it. I do not have the serial now and had sent it to TJ Friday early AM. I guess he was not there today. I was not going to keep Jeremy on hold while I got the box which was not close by. I know it is all good with PSA. Just a bummer for me but certainly no ones fault. These are complex machines and stuff happens. I have no hard feelings at all. The only big bummer is break in again. I wanted to see if they had a used one in new condition/Demo etc. but Jeremy said no. -Todd


#19

Thank you MR. McGowan. It is a bummer but at least you will take care of it. It seems to me the actual tft panel is bad. It now is completely blank and not on dim. I give up trying to calibrate it 1,000 times. The no sound before was my PC and not part of this afaik. At least it was not a big company like Sony, Luxman etc. That can turn into a disaster. Why I do business with small US based reputable companies on any large purchase. -Todd