Ultralink Issues


#1

Greetings,

I have a vintage Untralink DAC on approval (no money in it, yet). While it worked at first, after a few listening sessions it no longer wants to turn on. Previously, when it did turn on, it wouldn’t remember its last settings. It appears that the buttons are touch sensitive, but there’s no longer any response from the power button. Either that or the button is OK and the problem may be a failure in the power supply circuit or elsewhere.

Can anyone suggest tips for troubleshooting this situation? Does PSA still repair these? Also, is there a manual available to download? For the brief time that it worked, the quality was excellent and I’d like to keep it going.

Thanks!
Joe


#2

Welcome, Joe!

The Ultralink is getting up there in years. It was also made before the current iteration of PS Audio, but perhaps they can help.


#3

Unfortunately we cannot work on those with any measure of success. They were manufactured by Ultra Analog, a company long out of business leaving no parts behind. I do have schematics somewhere but they are probably of little use since most of the innards are sealed modules. Maybe time to move on.


#4

Thanks for your replies! Regrettably, it appears that I will have to return it.

Cheers,

Joe