USB connection not working


#1

After having my new Intel Nuc hooked up to my DS via USB for a day, I could no longer get sound. The DS display showed a red dot, indicating offline. The DS also disappeared from the
Roon zone list. Also, the Roon app was showing rapidly changing currently playing selections. First I rebooted my Nuc. Then I unplugged and replugged the USB cable. Then I turned off and on the DS. Still USB was offline. Then I fully powered down and restarted the DS via the back rocker switch - that worked! The DS is updated to Snowmass. The Nuc is fully up to date. Please advise why this happened and if a DS firmware update is needed.

Update: I think both times the connection was lost, I had tried to select an internet radio station in the Roon app. Definitely the second time I selected it, the WQXR stream, I heard a little blip, then the connection was lost as the display showed the red offline dot.


#2

When I experience a USB problem which was with a long cable, I tried a short cable, had to move laptop closer. When it worked I immediately went back to the longer (desired) cable and it worked. Why I don’t have any idea.


#3

This link looks related: Direct Stream USB Audio device dropping on Mac

And here is my ticket with Roon on this: https://community.roonlabs.com/t/roon-nuc-ps-audio-directstream-dropped-usb-connection/53969/8?u=peter_cullen


#4

@tedsmith Do you have any ideas for this?


#5

Not really, from the description it doesn’t sound like the DS or USB cable.

Still with USB, always try a (possibly cheap) Certified USB cable. If it works then your regular cable might be out of spec (and many “audiophile” USB cables are.)


#6

P.S. See


for info from Roon that sounds like it could be this bug. If it is then it happens when going from 16 bits to 24 bits at the same sample rate.

PS Audio engineering may need to see of the fix in https://www.xcore.com/viewtopic.php?t=6417


#7

James, is it possible to supply a new xmos chip that I can install myself? Can this problem be fixed in the field?


#8

Are you no longer able to get a USB connection now?


#9

No, I can get a connection. But it breaks under the circumstances I previously described, which matches the issue Ted has raised.


#10

Is there an update on this issue? I have a more straightforward use case to replicate the problem. Switch from Leanne Lehavas Unstoppable to Snarky Puppy Thing of Gold. That will cause the USB to fizzle out every time for me. On one occasion during reboot, the display went completely white. I rebooted again and got the display back.


#11

BTW, this is the scenario Ted described. This is going from 24 bit to 16 bit at the same sample frequency, in this case 44.1Khz