USB DAC Driver


#1

Hi,

I´m trying to install the USB DAC driver, and when the setup wizard ask me to unplug and replug the DAC it does not see it.

I´ve tried pretty much everything in the boo, reboot both the computer, mains on and off, switched cables, still does not work.

Help will be appreciated.

Cheers

Luiz


#2

I’ve been struggling to re-install the driver in hopes of dealing with a problem I’ve been having with my NPC. I also got caught in that endless loop of being told to plug (or replug) the device. Here are some things I have done.

  1. If you have tried to install the driver without success, you may have an incomplete or unsuccessful install that prevents further installations. Go to the Device Manager in Windows and see if there are any PS Audio USB devices listed; also click View/Show Hidden Devices. If anything shows up, uninstall from the Programs and Features applet in Control Panel.

Then check Device Manager again (with Show Hidden Devices turned on). If you still see anything, remove it by right-clicking and selecting Delete. Unplug the USB cable, reboot the computer and try again.

If that doesn’t work, try using a utility that checks for the presence of leftover pieces of old installs. I use one called Revo. It found a couple of Registry entries for PS Audio, which I told it to delete.

  1. The guys at PSA tech support asked me to reinstall the firmware on my NPC. This may or may not be appropriate in your situation.

  2. I ran the setup.exe program in the PS Audio Driver folder by right-clicking and choosing Run as Administrator.

I do not know which of the three steps, or combination of steps (super-clean uninstall, firmware reinstall, Run as Administrator thing) did it but I was finally able to get the driver installed. The Run as Administrator option does not seem necessary, since when I just double-clicked on the setup.exe file Windows asked me for permission, which I gave. But with these things who knows???

Good luck. pulling-hair_gif


#3

Thanks for the really helpful advice, running as admin and another USB cable swap did the trick.


#4

Glad you got it done and thanks for letting us know what worked! There really has to be a better way. (And I’m just not picking on PSA here; USB audio drivers on Windows are often a pain.)