VinylStudio Mac DSD problems


#1

I have been using VinylStudio Mac to record 96/24 PCM but my attempts to record DSD have all failed. I have the latest version (8.6.2), which I had to get from http://www.alpinesoft.co.uk/VinylStudio/home.aspx as the Mac App store is still selling 8.3 (I think), which does not support DSD. I followed the instructions in the earlier PSA tutorial and also the VS help file but every time I try (and I’ve tried every combination of settings I could think of) I get the following error, even though the NPC is set to DSD (standard rate):

The incoming audio (PCM) does not match the DSD setting in the DSD Input dropdown (DSD). Please either:

a)change the dropdown to match the DSD setting on your input device, or

b)change the DSD setting on your input device to match the dropdown.

Then click Retry.

If you have a PS Audio NuWave Phono Convertor, set the recording level slider to maximum when making DSD recordings. Some other recording devices may also need this.

Check also that:

-‘Enable DoP detection’ is enabled in the {recording_options_dialog}Recording Options dialog (it is, by default).

-The correct input device is selected in the Input Device drop down.

As noted, I followed these instructions but I still get the above error. I see that there are more recent firmware versions for the NPC than the one mine came with. Could this be the problem? Should I upgrade firmware in any event? Has anybody successfully recorded DSD with VinylStudio Mac?


#2

Hi,

Did you set the recording level slider to maximum? That’s the usual cause of this problem (i.e. you need to do this).

Paul, your setup instructions don’t mention this. In the case of Windows, you need to do it (with the PS Audio ‘native’ driver selected) before selecting ASIO.

And I would upgrade your firmware, yes.


Paul Sanders, AlpineSoft.


#3

Thanks Paul, it’s fixed


#4

Thanks Paul. Yes, I did set the level to maximum. I will try the firmware upgrade and see if that makes a difference.


#5

So the next question is how to upgrade the firmware on the NPC. I couldn’t find any instructions. I downloaded the NPC .46 USB install files and copied them to the root level of a FAT32 formatted USB stock. Turned off the NPC at the back panel. Put in the USB stick in and turned on the NPC. It started up the same way it always does. I waited a half-hour plus but the front panel still shows version 00.42 installed. Same after restarting the NPC. I also tried the .44 files but again no apparent results. What am I doing wrong?


#6

There is a tutorial in the How To section of our website. Did you unzip the files?


#7

Thanks Paul. I looked at that page but somehow did not see the first item. I did unzip the files (I downloaded on a Mac which unzips automatically). The instructions say to use a stick with 1GB or less. I don’t own anything that small so I used a 2 GB formatted FAT32 at first. No dice. I reformatted it as FAT16 (on a PC, can’t do it on a Mac as far as I know). No change. I found a 1GB SD card, formatted FAT16, put it in a reader and plugged that in but still nothing. Each time the NPC acts normally, i.e., as if no USB stick is inserted. I’m stumped.


#8

With regard to VinylStudio recognising incoming DSD, please check also that:

  • You have selected DSD on the NPC front panel.

  • ‘Enable DoP Detection’ is checked in the Recording Options dialog (it is, by default).


Paul Sanders, AlpineSoft.


#9

Yes as to both. One interesting point is that if I change from single rate to double rate DSD in Vinyl Studio it also changes the NPC so the two are communicating. Between this and my inability to upgrade the NPC’s firmware I’m beginning to suspect I may have a defective unit. My DS DAC kit is due to arrive today so I won’t be playing around much with the NPC for awhile. I should also be able to see if the DS recognizes DSD coming out of the NPC.


#10
stevem2 said Thanks Paul. I looked at that page but somehow did not see the first item. I did unzip the files (I downloaded on a Mac which unzips automatically). The instructions say to use a stick with 1GB or less. I don't own anything that small so I used a 2 GB formatted FAT32 at first. No dice. I reformatted it as FAT16 (on a PC, can't do it on a Mac as far as I know). No change. I found a 1GB SD card, formatted FAT16, put it in a reader and plugged that in but still nothing. Each time the NPC acts normally, i.e., as if no USB stick is inserted. I'm stumped.
I spoke with Dave our director of engineering. He told me he's seen 3 other instances of this. In each case, sending a pre-loaded USB stick did the trick. So something is whacky in how you're loading it. We're not sure why this happens to some people.

Can you contact dave@psaudio.com and give him your physical address? He’ll send you a new stick. Sorry about that.crying_gif


#11

Thanks Paul. Dave reached out and he is sending me a stick. I’m really puzzled why it didn’t work. I tried downloads from both Mac and PC and FAT32 and FAT16 sticks. Files unzipped and copied to the root. I’ll take a look at the stick I get from Dave to see if there are any obvious differences. Greatly appreciate the support!


#12

I got the USB stick from PSA today (an 8GB FAT32 stick). It worked fine and I now have firmware .46 instead of .42. The only difference I saw between this stick and the ones I made from the downloads page was the latter has an extra file, LOADER.CFG.9999. I sent my stick to Dennis so maybe he can figure out what is going on.

That’s it for the good news. It did not help with Vinyl Studio and DSD. Again, I tried it with the NPC set for standard and double rate DSD. “Enable DoP detection” box was checked. I tried file types DSF, WAV and AIFF. My Direct Stream showed DSD being played over I2S. Volume slider at 100. Still, I invariably got the dialog above saying the “incoming audio (PCM) does not match the DSD setting in the DSD Input dropdown (DSD).”

I’m stumped. Since I also haven’t been able to figure out how to get foobar2000 to stream DSD files to the Bridge it’s somewhat academic at this point. Other than driving me crazy when I think about it.


#13

Can you email me a screenshot of VinylStudio’s Check Level dialog set up for DSD recording please? To take a screenshot:

  1. Press cmd-shift-4

  2. Press the spacebar (cursor changes to a camera icon)

  3. Click on the window you want to capture.

Then email me the screenshot file that appears on your desktop. Please send it to:

p DOT sanders AT alpinesoft DOT co DOT uk

Thanks.


#14

Done. Thanks Paul S.


#15

I got the screenshots, thank you. All looks correct so I’m a bit mystified as to the cause of this problem. I’d like to see the ‘raw’ data being sent by the NPC. Would you mind helping with this? Please proceed as follows:

  1. In VinylStudio’s Recording Options dialog, select WAV, 176 kHz, 24 bit.

  2. In the Check Level dialog, select PCM (that’s not a typo).

  3. On the NPC front panel, select DSD.

  4. Make a ~10 second recording, preferably of silence. Please keep it short to keep the filesize down.

  5. In the Preferences dialog, click on the topmost ‘View in Finder’ button.

  6. Navigate to the recording you just made. FIlename is artist~title~side1.wav, where artist and title are the album artist and album title respectively.

  7. Email me the file.

I will then take a look, see if I can shed any light on this. Thanks.


#16

I got the file, thank you, and the data stream is indeed not valid DSD (or, rather, DoP - DSD over PCM). It’s trying to be, in that the DoP markers are nearly correct, but some of the values are a little too small. I can’t explain this but maybe the NPC doesn’t ‘believe’ that the recording level slider is set at maximum and is scaling the samples down a bit as a result. I can’t think what else is going on. The USB audio driver, AFAIK, is bit-transparent, as is VinylStudio, so there should be no problem there.

Paul McG, I don’t know what further action you want to take on this (if any) but I think I’ve gone as far as I can go. Sorry I can’t be of more help. I know of no other cases, but the number of people recording DSD is small.


Paul Sanders, AlpineSoft.


#17

Thanks very much pauls. I very much appreciate your taking the time to try to figure this out. At least we have some idea what the issue is.

I’ll leave it to PSA as to whether they want to pursue this further. I can certainly live without being able to record DSD if it comes to that.


#18

@pauls and @adminpaul I just made an interesting discovery–the problem depends on which Mac I use. All of the above occurred using my 2010 MacBook Pro, which has the advantage of being easy to move close to the equipment rack. I also have a 2011 Mac Mini on the other side of the room. I had recently set up an iTunes/BitPerfect library on the Mini to experiment with. To reach my Direct Stream from the Mini (without running cables through the middle of the room where I would trip over them and damage the equipment and myself), I have been using a 2 meter Belkin USB cable and an 18 foot Triplite active USB extension cable (which I already had). Not exactly audiophile quality but it worked well enough to play with. It just occurred to me that I could switch the USB cable from the input of the DS to the output of the NPC, which I did, along with downloading the latest version of VinylStudio to the Mini (it would be nice if the Mac App store had the current version). I then set everything for DSD and it worked immediately. I didn’t actually record anything but the NPC said DSD, VinylStudio was set for DSD, I got no dialogs telling me VinylStudio was set for DSD but receiving PCM, and the volume level bounced up and down with the music.

This is not an ideal solution but, since the NPC is only sending data to the Mini, should the less-than-ideal USB cable(s) make any difference? Any thoughts on why the Mini worked and the MBP did not?

FYI, both Macs are running OS X 10.9.2 Mavericks and both have Core i7 processors (not the same ones though).


#19

Thanks for this. Most interesting. The long USB cable is over the specified maximum (5m / 16ft) but you might get away with it. Listen out for ‘glitches’ in your recordings. If you don’t hear any, you’re probably OK.

As for your Macbook Pro, can you send me the log created by System Profiler please (Finder - Menu - Go - Utilities - System Profiler, then Menu - File - Save As)? I’ll see if I can spot anything unusual. Thanks.


#20

Done. Thanks Paul.