What is wrong with my brand new PS Audio DACMK2

Hello, I just received My Brand new DAC,it i appears s well built but I can’t get it work or play with CD player used as transport. NO sound . I have connected it via COAXIAL or OPTIC cables, changed cables
changed Mcintosh MCD 350 as transport to Oppo 105 transport via COAXIAl or optic Link–still no sound, it has latest firm ware 3.5.1
I can turn on and off Dac with remote- thats it
Connection: MCD 350 coax OUT to DAC coax IN,
DAC -RCA s out to preamp INs-----connected to amp–speakers

When DAC is connected via Coaxial to CD transport it showed green dot on screen 44.1/16 -/- signs
what is wrong here, i plan to contact them on Monday and return it as i ewas told it might be soft ware issue, working on it-No sound??

It is possible you have to enable the inputs. Just guessing. I usually assume all inputs and outputs are enabled. Sometimes that isn’t the case.


Make sure the unit isn’t muted.

1 Like

Bummer! I’d suggest the following sequence(s) as a cold reboot for your unit. If after the second attempt it still does not provide an output STOP. I say this as I had a similar problem with a PST and the reset process ended up taking out my DSD Mk 1 DAC and sent a horrendous signal through my stereo system!

Turn the unit off with the remote, then turn off the power switch on the back, and disconnect it from its power source. I’d de-energize any inputs to the DAC to be safe and then remove all interconnects and let it rest for 30 minutes. Reconnect everything, power cord last, Re-energize all inputs. Verify position of SD card in back, for this first cold re-boot I’d recommend that it be out of its seated position. Re-power the unit with the rear power switch and power up from remote control. Verify input settings and volume setting at 100. If still no sound repeat changing one step, prior to re-powering the DAC insert the SD card, to attempt to reload the firmware. Re-power and hopefully you are good to go.
Others that have a DAC 2 may chime in with additional steps on how to confirm inputs are properly initialized.

Otherwise call the mothership requesting technical support, and possibly a return authorization if it can’t be resuscitated.

Good Luck!

1 Like

Welcome to the forum @audio5!

Have you tried a Factory Reset?

Have you ensured that the unit isn’t muted?

What volume do you have the DAC set?

1 Like

Check the DAC’s volume control with the remote.


Good thinking to suggest checking the volume. Upon power up volume is set to 25 which is very low.


Go into the menu and be sure that the Maximum Volume is not set at 0. If it is, then that is likely the issue. Turn it up (may as well put it to 100 to start) and then see if you have sound.


No it is not muted as i can up volume to 100 or zero without any break in silence. I have reset and booted from the rear toggle switch multiple times without success.
I have changed input via Remote but no luck with sound despite green dot withCoaxial connection.
I was so frustrated that i called mothership yesterday and told them-got no answer;Blame it on MCD 350 :)I did order a PS audio transport with HDMI cable and will see if Dac can make any sound as PSA transport will be a Match for DAC via I2S connection, though still no coax or optical connection.
We shall see,stay tuned.


1 Like

Well that’s disappointing, and to say you have more PSA components coming your way. Time for an intervention from the higher authorities.

What a bummer, I’d get a laptop and try USB and see what happens.

1 Like

Good idea.

Were you able to get ahold of us this week? Sounds like it’s either muted or volume is low. What do you have the volume set to?

hI, Jamesh
Only Coaxial connection with RCA cable, play music and display has green light(coaxial) and 44.1/16 on red book CD playing; BUT if I use SACD disc no sound and display has red light and coax,44.1/16, despite checking volume.SACD player(MCD 350) still showed SACD layer on.

I believe 44.1/16 displayed is connected source information, but no upsampling rate like 96-192/24 is displayed.

I tried USB input but still no sound when connected to my iphone /qobuz app.
I have tried resetting it multiple times, and changed cables.
Is it a damaged unit /board or what? software 2.5.1 ; I purchased this unit last week.
You are correct Coaxial worked only after Volume was changed from 25 to 100 and increased preamp volume to mid levels

From the Macintosh owners, manual:

“The Audio from playback of SACD Two Channel Layer and Multichannel Layer Discs is available at the MCD350 Analog Output Jacks and Connectors; the Digital Outputs will be muted.”


Another “benefit” from “Digital Rights Management” - the gift (from Sony) that keeps on taking.

1 Like

But I have connected Coax out from MCD350 to coax in( bypassing analog output ) and the preamp is connected to DAC.
When I put a SACD disc in MCD it should display on my PS dac as SACD not just coax 44.1/16 and worst no sound. I can push the disc/layer button on MCD to change between SACD/CD and stereo but nothing changes on the DAC screen.
Red book CD plays ok with coax connection
when I use optical cable- AQ Forrest green or others no music is heard.

Your MCD350 will not put out a DSD signal to the Mk2 over any connection. Only a PS Audio transport can play the DSD layer to the Mk2 (and then only over an I2S connection). As noted above by joma0711, this is a digital rights management issue (blame Sony and Philips). Most SACD players will convert the DSD layer to PCM and transmit that but it might require changing your player settings. The CD layer should play fine though so I’m not clear on what is going on there. Your MCD350 may only be using one output at a time so if it is set to coax it might need to be reset to use optical.

1 Like

Not sure you are following what he said. The COAX is muted (off) on purpose by the SACD player. SACD music is NOT supported via COAX or Optical due to DRM (Digital Rights Management). This was part of the design from the beginning.

You can either tell the player to ONLY use the CD layer. Or use the L&R outputs of the analog section of the player. The MKII does support I2S from a SACD player but only a few have that. The Mac SACD does not have that.

Many of us here on the forum have Ripped our SACD to DSD files and put on NAS and use some other software (Roon, Jrivier etc) to stream to the DAC. Its more complicated, but not disc spinning. You will find the same with almost every DSD DAC & SACD Player out there. They support either some proprietary (Mac) or I2S (PS Audio) or HDMI (most players) to AVR/Prrocessor. But the MKI only does I2S over HDMI.


Thank you,
It has been a very helpful learning experience in quest for high resolution music. I did try USB cable with DAC and could see resolution of 96/24 and music played.
I removed the MCD from the chain and inserted a PW SACD transport with an HDMI /I2S cable that had arrived today. it started playing as CD 44.1/16 on displays until i changed the menu setting to DSD layer . then i could see DSD64 on display.
MCD350 automatically selects the disc layer,if it is hybrid it defaults to SACD. but I can’t use it with a PS dac properly.