JRiver Mac mini PWD bridge


#1

I went through the posted procedure to set up JRiver on a Mac mini to PWD MK2 with bridge and ran ino issues. Basically I ran a direct connection between my Mac mini and PWD MK2 with bridge using CAT6 cable (no router involved). When selecting “original” I get no sound. However, when selecting “Specified output format” instead sound comes through fine. My guess is that the setting you recommend is “bit perfect” while the other is not because with the later setting I do not have volume control options, nor do do I have playback options available. Further, the audiopath says “not using JRiver audio engine”. Can you help me rectify this.
Thanks
Tom


#2

For starters you would have to use a crossover cable for a direct connection. A direct connection is not as simple a process. This article might help: http://www.audiophilia.com/wp/?p=11352

Generally it is easier to go through a router, or a switch that is connected to the router.


#3

Thanks for your reply. Yes, that is the article I used to set it up as it is currently configured. I guess I fail to understand the difference between a cross over cable and a regular CAT6, but if that is the only thing that makes a difference I am all for it. Problem with inserting a router is that my modem/router/nas are two floors beneath my 2-channel listening room where I have the DAC.


#4

A crossover cable has a couple pins reversed from a regular cable. You can also get a cheap adaptor and then use a regular Ethernet cable. Let us know how it works out. I haven’t heard of too may people going this route. Some people have used powerline Ethernet adaptors that plug into the wall outlets when it’s not practical to run Ethernet cables all the way to the router.


#5
stevem2 said For starters you would have to use a crossover cable for a direct connection.
Not necessarily. The later models Mac mini have an auto-mdix ethernet port.

#6

Thanks. I stand corrected. My newest Mini is a 2011. But then I’ve never tried a direct connection anyway.


#7

Well I tried the cross-over cable (CAT5e) to no avail. There must be a setting in the MC software I am missing. I just bought a late 2014 mac mini. Again, it is working fine with “Specified output format” option under the audio settings, but not sound using the “original” option. The other thing I noticed is that despite playing a 16 bit 44.1 Khz wma file track the LCD on the PWD says 24 bit 44.1 khz wav file. Any thoughts?


#8

I don’t know what’s going on with your setup. I have “original” and 24-bit selected, the audio path shows “not using JRiver audio engine” and I have sound. My DS is not passing the bit perfect test but it’s possible that’s related to the Bridge 2. Gordon’s “How To” on JRiver and the Mac is consistent with my settings.


#9

Are you using a router or an ethernet switch to connect your mac mini and DS? I posted the same question on the JRiver forum but not getting any replies yet.


#10
TomH said Well I tried the cross-over cable (CAT5e) to no avail. There must be a setting in the MC software I am missing. I just bought a late 2014 mac mini. Again, it is working fine with “Specified output format” option under the audio settings, but not sound using the "original" option. The other thing I noticed is that despite playing a 16 bit 44.1 Khz wma file track the LCD on the PWD says 24 bit 44.1 khz wav file. Any thoughts?
MC is transcoding the file because the bridge won't play WMA files.

Dennis


#11

I have the DS and Mac Mini plugged into a switch, which is then connected to a router. I have had few connection problems this way. It sounds like you are connected OK because you get sound using “Specified output format”. Otherwise I would have suggested trying a switch with a powerline adaptor to connect it to your router as people have had issues with direct connections. But I am far from a network expert, or a JRMC expert for that matter. It has mostly just worked for me but the configuration options can be bewildering. I assume you have already double checked your settings against Gordon’s “How To,” such as selecting Audiophile 24-bit DAC, which is supposed to take care of a lot of the settings for PSA DACs.


#12

Okay, so if I converted all my wma files to say wav file or flac file format this approach should work. I will give it a try and let you know how it works out. Thanks for you replies.