Volumio DSD file playback

Hi,

A Raspberry Pi running Volumio is connected to the Directstream DAC via HDMI port so the DAC is used as an i2s DAC and it plays music fine. However when playing DSD files, Volumio indicates DSD 2.82 mhz/1 bit but the Directstream DAC indicates it’s playing PCM /192 khz/24 bit and not a DSD signal. Can someone tell me what’s going on?

Thank you.

Peter

Any chance anything in the chain is doing DSP, setting the volume or other things that might keep the system from being bit perfect?

In the How To pages here is a description of how to run the bit perfect test - http://www.psaudio.com/ps_how/how-to-run-a-bit-perfect-test-with-directstream/: it should help narrow things down a little.

Hi Peter, I’m also trying to use a RasPi 2 over an I2S interface with Volumio but it does not work. Lots of ticks, volume drops etc. PiCorePlayer works perfect. What is the I2S DAC name that you are using for the DS ?

Best regards

Kurt

I’m using a Raspi 3b+ running Volumio. I2S signal is fed by a Allo Kali ReClocking Unit to an LDVS converter and finally to my PWD MKII.

It plays w/o any problems. Fast and Reliable.

@sugano: did you activate the DSD over PCM option?

hi kurt,

i’m using directstream dac

I’ve got the Stellar GCD hooked up via I2S over HDMI to a 768kHz/1024 DSD I2S Re-clocker sitting on top of a Raspberry PI 3B+. The Pi runs Volumio.
Volumio appears only to show the original format/sample rate/bit depth of the file, but it does seem to transcode automatically (and obscurely). On my desktop system, also Volumio , my Meridian Explorer 2 suddenly could play DSD - transcoding has to be happening in Volumio.
Weirdly, it will play DSD64 (2.8MHz) files in DoP mode (LEDs on the reclocker for DoP input, DSD output) but DSD128 switches to PCM. DSD direct goes to PCM as well. Maybe it is a simple configuration thing. I am using the R-PI DAC profile on Volumio to enable the connection to Stellar. The “Generic I2S DAC” profile fails to play 16 bit files, the other profiles I tried didn’t play.
It is still not ideal. I have to reboot Volumio almost on a daily basis - the connection over I2S fails, I assume there is a need there to open/close that connection that Volumio (or that particular profile) doesn’t handle.
Would it be too much to ask for PS Audio to write a proper profile for the I2S connection? Here is the I2S profile page from Volumio . Thanks in advance!

[I just noticed that you are asking about the Stellar GCD, I’m pretty sure my answer below applies to it as well as the DS.]

PS Audio uses “standard” I2S (Bit clock, data and left/right. Nothing else, no protocols, etc.) The I2S profile page seems to be not for the DAC but for the HAT you might be using - none of the options apply for PS Audio DACs.

The DS doesn’t have any configuration settings for I2S. There’s no concept of opening and closing the I2S connection. The DS doesn’t care about 16 bits vs 24, vs 32… The DS doesn’t support anything over I2S except audio (e.g… don’t use the I2C lines and there’s no mixer, etc.) The DS doesn’t need any signaling except the raw audio. All of these issues are issues with your I2S source and we aren’t the best ones to debug that for you. Perhaps someone else here has a similar configuration to yours and can chime in with suggestions.

3 Likes

Thanks Ted for the prompt response, that is good to know as it narrows down the daily reboot issue significantly. Everything else is working right now, most my tracks are PCM or DSD64 anyhow, so it’s just about tinkering… hobby more than actual need :wink:

One question on the Stellar GCD. When using I2S, the screen doesn’t show Format or Sample Rate. Is this normal?
Again, not that it matters that much to me, just the “hobby more than need” thing.

Sorry I can’t answer, hopefully someone from PS Audio or someone who has a GCD can answer.