Can't get optical fiber to work with DS DAC


#1

So I have been trying to setup optical fiber conversion from ethernet for my DS DAC and it’s not working for some reason. I purchased a pair of TP-Link MC210CS and connected with Lynn SCSDUPSM-3M 9/125 Duplex Single-Mode Fiber Optic Patch cable and powered it up to work as an ethernet connection between my switch and my Mac Mini. No problem. It won’t work with the DS DAC, though. I switched the toggle switch from “forced” to “auto” and nothing. For whatever reason this setup doesn’t work with the DS DAC. I am pretty sure I intentionally used the same unit referenced by another DS DAC owner on this forum, but no dice. Does anyone have insight as to why this isn’t working? I thought the only important designation on these converters is that it be single-mode fiber and not multi-mode. This is a “10/100/1000 Mb” unit so it should good with any switch. Any help is greatly appreciated.

Adam


#2

Are you referring to connecting the TP-Link between the switch and the DS ( I assume Bridge? )

I am not 100% positive that you need “1000 Mb” capacity.

Do you have the transmit and receive fibers connected correctly?

It should be transmit > receive between the units, not transmit > transmit & receive > receive.

I believe that you also have to rest the media converter after you change any selector switch settings.


#3
MrDerrick said

Are you referring to connecting the TP-Link between the switch and the DS ( I assume Bridge? )

I am not 100% positive that you need “1000 Mb” capacity.

Do you have the transmit and receive fibers connected correctly?

It should be transmit > receive between the units, not transmit > transmit & receive > receive.

I believe that you also have to rest the media converter after you change any selector switch settings.


Thanks for the reply. I agree - I don’t think I need Gigabit speed for the converter. The 10/100/1000 designation suggests it will work with all switches. From all I have seen, though, it shouldn’t matter with the DS DAC. I know another DS owner made this one work.

I’m pretty sure I had everything connected properly. It worked connected to my Mac Mini and just disconnected the ethernet from the MM and connected to the DS DAC and no dice. There is no “transmit” or “recieve” on these units that I know of. They are identical and only have a toggle between “forced” and “auto”. I tried all combinations of that and they don’t work. Are you saying there is a orientation to the fiber cable, itself?

As for resting, I re-cycled the power after switching with no luck. After re-testing, I plugged back into the MM and it worked fine.


#4

I use two pair of the MC100CM, one pair between my NAS and switch and one pair between the wireless hub and the switch.

I found no benefit between the switch and my Sonore SSR.

The duplex fiber ports on each converter have each side labeled, TX ( transmit ) RX ( receive )

My duplex fiber cables had a “1” on each end of one cable and a “2” on each end of the other cable.

Cable “1” runs from TX to RX and cable “2” runs from RX to TX.


#5
MrDerrick said

I use two pair of the MC100CM, one pair between my NAS and switch and one pair between the wireless hub and the switch.

I found no benefit between the switch and my Sonore SSR.

The duplex fiber ports on each converter have each side labeled, TX ( transmit ) RX ( receive )

My duplex fiber cables had a “1” on each end of one cable and a “2” on each end of the other cable.

Cable “1” runs from TX to RX and cable “2” runs from RX to TX.

My duplex fiber ports are slotted so there's no way to incorrectly plug them in, I think. I'll double check when I get home, but I think they are oriented correctly. I'll let you know.

EDIT: The fiber plugs are slotted and cannot be plugged in incorrectly,


#6
amgradmd said ; in fact some devices

… I purchased a pair of TP-Link MC210CS… This is a “10/100/1000 Mb” unit so it should good with any switch. Any help is greatly appreciated.

Adam

I bought a pair of TP-Link MC100CM converters to add optical isolation between my switch and renderer/DAC, after checking on-line what was required for handling an ethernet stream to a renderer/DAC. Many (most?) only need a maximum of 100 Mbps; indeed some are designed to not accept higher rates (e.g. Sonore Rendu and some Linn models). I asked Sonore why this limitation was imposed and got the reply that a stream of 1000 Mbps could bring with it RF interference problems.
The MC100CMs have worked perfectly with the BridgeII / DS combination.

#7
MrDerrick said

I use two pair of the MC100CM, one pair between my NAS and switch and one pair between the wireless hub and the switch.

I found no benefit between the switch and my Sonore SSR.

An interesting result, however did you try putting optical isolation in only the last leg, i.e. between your switch and the DS, with wired ethernet connection between all the upstream components: NAS to switch and wireless hub to switch?

I’d guess you would get similar SQ to what you have now - one leg of optical isolation should break any wire-bound electrical interference path. In case the switch introduces any electrical interference I reasoned the best place for isolation would be the last leg, between the switch and the DS.

David


#8

I tried everything I could to get the optical fiber to work with the DS using the TP-link MC200CS. I know that the MC100CM modules work for the DS DAC so I went ahead and ordered a couple of those units. Worst case is that it doesn’t work for the DS and now I have isolation for my switch from my router! I’ll let you guys know how it works out.


#9

davidl,

From what I understand, great lengths were taken in the design of the SSR to block interference.

I did try between the switch and SSR, but there was no difference between using the media converter and a Revelation Audio Labs Ethernet cable.


#10

I received the TP-Link CM100M units yesterday and installed them between the switch and the Directsream DAC. I selected all the dip switches in the up position and it fired up without any issues. After listening to my standard reference files, including Tidal streamed via Roon, I came to a few conclusions:

Playing vinyl DSD rips showed the optical isolation to be a little more dynamic, just a touch. Not jarring by any stretch. The music was a little more palpable. I’m not sure I could pick it out in A:B comparison.

Playing hi res 24/96 files, RB rips, and DSD downloads also pretty much followed my experience with the DSD vinyl rips. Just a little more dynamic and hopefully not expectation bias.

Things got interesting when I listened to Tidal streams via Roon. I immediately noticed the music was more palpable than before. It was like the improved dynamics were on turbo. Percussion was more crisp and cymbals more lifelike. In particular listening to Nickel Creek, Chris Thile’s mandolin strikes on “When in Rome” seemed to jump out with more energy and all the instruments had more distinct percussion and separation. This was not a subtle difference. I could easily blind pick the fiber isolation from the non-isolated.

So why is this, I wonder? I can only ascribe this to the fact that streaming is more susceptible to upstream noise than my archived recordings, I guess. Just to see how good Tidal files were sounding, I compared The Doors Morrison Hotel DSD 64 from HDTracks to the Tidal version and could honestly not hear a difference. Not that there was a huge difference before, but now there was none. The Tidal version sounded great. And just as importantly, I have not experienced any momentary distortions I would occasionally hear while streaming. I wishfully attributed this to my non-shielded CAT6a ethernet cabling picking up RFI from the mess of cords I have behind my system. Now the optical fiber crosses the power cords, etc, and is now theoretically more immune to such effects. Theoretically.

So I’m very happy with the fiber isolation. One quirk I noticed was while listening to DSD 128 (or which I have a lot of vinyl rips) to the Bridge. Roon apparently negotiates with the DS DAC and converts DSD 128 to PCM 352 automatically and then to 176. This has gone on without a hitch without the optical isolation. But after isolation, I get a harsh digital noisy sound obscuring the underlying song. I had to go into Roon and enable DSP and down-sampling to DSD 64 to make the digital noise go away. This can’t be a problem of bandwidth, I would imagine. It’s not a processing issue since it can transpose into DSD, which takes more processing power than the conversion to PCM 176. I have no clue why that is. Weird. More experimentation is needed to figure out what the cause is.


#11

The hash problem sounds like one of two problems:

  1. DoP with volume or DSP applied. Probably some processing stage isn’t bit perfect.

  2. Perhaps the software is converting to 352.8k but the bridge can only do 176.4k so there’s crap as 1/2 the data gets thrown away somewhere.

Tho I don’t have your setup I’ve seen both of the above at times with other setups.

As you say explicitly converting DSD128 to DSD64 or to 24/176.4 is the best solution (I’d recommend 24/176.4k, all other things being equal, to avoid extra steps along the way.)


#12

Thanks for the input Ted! I will try to find the cause and report back. Let me ask you one thing: does it surprise you at all that I find more improvement in streaming RB files than hi res stored files? I’m going to repeat the comparison tomorrow just to verify my observations, btw.


#13

Surprise me? Not really. Would I have predicted it? Probably not. I’m not too surprised that there are differences: Let’s assume that there are differences when using different players/renderers on the PC. If so those differences have to be from jitter, RFI, groundloops, etc. Jitter isn’t a big problem in the DS, but having optical connections will lessen RFI from the cable itself and should break groundloops (or at least change them.) So your report amounts to saying that in your system the streamer produces more hash from the computer than playing the stored files. I’m not surprised at that, tho in someone else’s system it might be different.


#14
Ted Smith said

The hash problem sounds like one of two problems:

  1. DoP with volume or DSP applied. Probably some processing stage isn’t bit perfect.

  2. Perhaps the software is converting to 352.8k but the bridge can only do 176.4k so there’s crap as 1/2 the data gets thrown away somewhere.

Tho I don’t have your setup I’ve seen both of the above at times with other setups.

As you say explicitly converting DSD128 to DSD64 or to 24/176.4 is the best solution (I’d recommend 24/176k, all other things being equal, to avoid extra steps along the way.)


I found the problem! As it turns out, Roon wasn’t downconverting to 24/176.4, after all. It was downconverting to 32/176.4! I had totally missed on the signal chain page that it was floating from 64 to 32 bit. I Simply went into the device setup and under “Playback” there is a setting called “Max Bits Per Sample (PCM)”. I selected that and it now downconverts DSD 128 to 24/176.4 without issue. It sounds great too! Maybe there’s a bug in the negotiation between Roon and the DS DAC? Is this a DAC or a Roon issue, I wonder?