Can't log in to Roon

I can no longer log in to my Roon account/app or Roon Arc. No matter what device I use, I get the following error after I enter my password. I already have a Roon lifetime license.

There was an error logging in: InvalidRecaptcha

I have tried my PC and laptop running Windows 10 with Edge, Chrome and Firefox. Also tried my Android phone and Android tablet. In every case, there is no place to enter a Recaptcha or a I am not a robot checkbox.

I tried changing my password which did not help. Now I can’t enter the issue on the Roon Forum because it requires you to log in first. So it’s catch 22. I can’t log in to my account and I can’t log the issue. I can’t believe that Roon has not figured out the issue and fixed it yet.

I found one Roon support thread with this link to a Recaptcha test page.

Link is reCaptcha test page

This worked fine. The user who started the thread said this: I needed to end chrome in tasks and in appdata change default into old default. Then start a new chrome session. Now all works again.

I tried this and it did not work for me. I am running Roon on my Synology DS1621+ and everything worked fine when I first set it up.

Has anyone found a solution?

As of this morning I was able to log in to my Roon and Roon Arc apps. There was nothing I did to correct the problem.

Good to get back in, but it would be nice to know why.

Dear Fellow Roonies,

Here is a riddle for you:

I updated the software from my iMac but it won’t reboot. The Roon symbol comes up and the program just churns, if you will, and never gets past the initial startup page with the Roon symbol displayed.

Interestingly enough, the software is still available on the network - I can play Roon without issue using my iPhone to access Qobuz, Tidal and my files on my network.

I just can’t get past this screen and the churning Roon icon:

I have tried several reboots (both Roon and the iMac) and allowed “the churn” to run for hours.

I am really lost with this one. Here is the Roon Support posting/reference, if you care to chime in with suggestions (there or here):

Roon software fails to boot after update on macOS (ref#36O5NS)

[So far, no takers on the Roon Support page]

I will not be able to chase down recommendations for a couple of weeks, but all suggestions are welcome.

Thanks in advance.


Have you tried to reinstall Roon? My MBP runs Sonoma and I don’t have a problem running Roon.

Not yet.

Is this a matter of pulling an .exe file stored on my iMac somewhere or going to a Roon site?

I did not see any options on the Roon website when I did a quick search.

That’s what I was thinking. Remove Roon from you Mac and reinstall it. It is possible that Roon program was corrupted for unknown reasons during the iOS update.

I recently found a post suggesting that changing a browser setting not to block cookies might be the answer.

I’ve found that most Roon problems can be solved by uninstalling and reinstalling the app on whatever device you are using it on.

Hope this helps.

1 Like

Have you tried forced quitting of Roon. Command-option-escape

I ended up reinstalling Roon and using a backup to get back on line,

Also had to reduce the amount of data on my iMac. It appears there was not enough storage for Roon to update and function. I am going to have to host Roon Core on a different device or move a bunch of my music library to a NAS.