Problem connecting Roon to AirLens

Roon installed on MacBook Pro connected to AirLens via Ethernet cable does not recognize AirLens. It seems the AirLens ought to be a choice under Audio Settings, but all I see is host computer and other Apple products on WiFi. Any thoughts on what I am doing wrong?

Welcome to the forums Richard,

You should connect the Airlens to your router and make sure that your mac is also connected to your home network either through wifi or by a wire to your router as well.

That should solve the problem.

Welcome, Richard

Have you been to the “Audio” page in Roon settings where you search for and activate/enable devices?

PS

Welcome to the forum.

I am unclear as to the necessity of using a router as the AirLens and MacBook are the only two Ethernet devices. There are steady green and flashing amber LEDs at both end of the cable. This suggests to me that they are in communication.The computer is connected to the home network via wifi, but again I do not understand why this would be relevant.

I think you might be over thinking the situation. Both devices need a network connection and the way you have it configured I don’t that the AL is getting internet. I don’t think your Mac can ‘transfer’ its Wi-Fi to your AL, so plugging the AL directly into the router would be the solution.

1 Like

The router assigns a network address to the Airlens and your PC. They don’t know how to talk to one another without those addresses.

Think of it like this. Let’s say I don’t know your address but I want to send you a letter. Without your address, I could not get the letter to you. If you think of the music as being like the letter, hopefully, you understand why the music cannot get from your PC to the airlens.

I suspect your question will be that they are on the opposite end of the wire from one another; why can’t they just talk to one another? I completely understand that perspective, but unfortunately, that is not how networks work. Each of them needs an address, and once they have an address, they can talk to one another.

2 Likes

Imagine that the MacBook is you and the Airlens is your dog.

And there’s a big air tank in the basement distributing the air.

You need both you and the dog to be directly connected to the air tank.

Instead, the dog is trying to breathe through YOUR nose.

2 Likes

all I see is host computer and other Apple products on WiFi.

What is the device that is providing WiFi for your other Apple products?
That device is likely a router - the heart of your network. It’s the thing that is assigning IP addresses to your MacBook and other Apple products.
The AirLens needs to be connected to that device either hard wired via ethernet cable or WiFi.
The AirLens should NOT be connected to your MacBook.

Do you have internet access on your MacBook and other Apple products?
Your modem could also be your router. That is fairly common.

Regards
Mark

2 Likes

Perhaps I am being hopelessly dense, but I cannot understand why I want WiFi connectivity. All I want to do, for now, is send music files from an SSD attached to my computer to the AirLens and then in to my MK2 DAC. If I later want to use a streaming service I can see the utility of WiFi, but is this necessary for my set up? I have both the computer and AirLens connected via Ethernet cables to an Ethernet switch. In Roon under Audio Settings it shows “This Mac” as System Output but I see no means to designate the AirLens as a destination. It appears that the PS Audio documentation assumes that there is a single default system set up, but assumes the characteristics of this set uo are so self evident as to not require description.

You don’t need wifi, if it’s connected to the switch via an ethernet cable. (You say it’s connected to the switch, but directly, correct? You said before it was connected via ethernet directly to the Mac.)

I don’t have an Airlens, but if it’s roon ready, as long as it’s active on your network with an IP address (and connected to your DAC), you should see it in the Audio settings like any other endpoint.

Can you share a screenshot of the Roon audio settings screen?

…but not connected directly to your computer. I had a similar issue once when I tried to use a NAS as a Roon- and/or JRiver Media Center-accessible place to store music. The music software packages were hosted on my iMac but they could not “see” the NAS when I had it directly connected to the iMac instead of “installing” the NAS on the network.

I moved the NAS to a location where I could connect it via a switch to the router (my iMac is connected to the network wirelessly, by the way) and all is well.

FYI: @richardmallory

I suppose one advantage of using wifi is that you have no chance of accidentally connecting the airlens to the computer :grin:

Yes, “I’ve got that going for me, which is nice”.

From your original description, it seemed like you ran an ethernet wire between the ethernet jack on your computer and the ethernet jack on the Airlens.

Let’s get some basic understanding out of the way. Remember that devices on a network cannot talk to one another if they don’t have an address. Switches are like a network expander; they allow you to connect more devices to your network so all those devices can talk to one another, but they do not assign addresses to devices connected to them. The router controls the assignment of addresses on your network (LAN). If the switch is not connected to the router, the devices connected to the switch cannot get an address, and they won’t be able to talk to one another. Is the switch connected to your router with an ethernet cable?

If the switch is connected to the router, both the airlens and computer are connected to the switch, and Roon is running on your computer, you should see the Airlens in Roon under the Settings > Audio display like the image below, but your airlens may show the enable button next to it. If so, click that button to enable the airlens.

Once you enable the Airlens, you should be able to select it as the output device. Once that is done you should then be able to select music to be played to it.

4 Likes

I initially ran an Ethernet cable directly to the airlens. This time the airlens and computer are connected to an tp-link Ethernet switch. I do not see the airlens as an option in Roon under Settings > Audio. also, I have been unable to connect over Wi-Fi, after disconnecting the Ethernet cable, by pressing WPS on both units. I believe my airlens may be defective because the LED below the WPS button blinks amber non-stop. As soon was the unit is powered on the LED is briefly blue, but then begins to blink amber.

Is your switch connected to your router via an ethernet cable?

No. The switch has two connections: computer and airlens. The Wi-Fi router is RF. The airlens manual suggests that a wireless connection is possible where Ethernet is impractical. I, of course, disconnected the Ethernet from the airless before attempting WPS connection.

If you want it to work, you will need to run a third ethernet wire from your switch to your router. After you’ve done that, give it a minute to at most 5 minutes, and you should be able to see the airlens in roon.

If you still don’t see the airlens after 5 minutes, shut down both the airlens, and the computer, wait 2 minutes, then turn on the airlens first, wait a minute then turn on your computer. Once your computer boots, roon should see the airlens.

1 Like

I am no expert, but don’t think your switch is on your network. It can be connected by Wi-Fi or Ethernet cable but it should be connected to your network via a router in order to work.