Network doesn't see my new Airlens: suggestions?

Today UPS delivered my new AirLens, which I connected to my system via Ethernet cable.
The AirLens is my new Roon Core, replacing my Roon Nucleus
The Airlens is connected to my MK 2 DAC via IS2 (this is my Roon Audio Device)
Roon software runs on my Macbook Air, which uses wifi.

This setup has worked very well for a couple of years until today, when I replaced the Nucleus with the AirLens: but the network cannot see the AirLens: neither my Macbook Air nor my Mac Mini can detect the AirLens. The AirLens Ethernet light is green, and the orange light is blinking, so there is a network connection. I have tried turning off my Mozilla VPN and also I have told Mozilla VPN to accept local all devices connected to the network. I have rebooted everything, including network components, computers, and the whole stereo setup including the AirLens. Nothing has worked. I called PSAudio and they were at a loss. I’m stuck here and would really appreciate suggestions!

Your first step:

Check the IP of your Mac Mini, Macbook and Air lens, their ip should be in the same subnet (192.168.1).xxx. also, make sure your Airlens is not in a guest wifi.

Thank you! At the risk of seeming completely out of it, how can I tell the IP address of the AirLens when it does not appear on the network? Thank you.

1 Like

If I understand it correctly, the Airlens is not a roon core device. It is a roon endpoint. So you will need a roon server on your network: the airlens will not replace your nucleus. Try running the nucleus on your network, and see if you roon software find the airlens.


To find the address of your AirLens, log into your router; it should display all the connected devices with their addresses.

Or you can use a utility like Fing.

1 Like

Make sure everything is connected properly.

Power down the whole digital chain.

Power up each digital bit and bot starting with the router and then each piece of kit downstream of the router, concluding with the AirLens

Reboot any music rendering software you are using.

Chances are, you will then detect the AirLens as an endpoint.

I am assuming you erred when you posted “AirLens is my new Roon Core…” As others have noted, the AirLens is just an endpoint/Ethernet bridge/Streamer (depending on you definition of a streamer).

I hope you get it sorted soon.

Good luck.

I too have been having trouble getting my AirLens connected with JRiver Media Center and MConnect. Initially it was visible, but I made some network changes and lost it. Not long after that I got a new router/gateway from my ISP and had more problems. MConnect was working, sort of, but JRiver and its controller JRemote were not. My solution was in the anti-virus software (McAfee) and it’s firewall. Can’t say this is the same situation for you but you can shut off a firewall to see if it solves the problem. Once I determined that was my problem it took some trial and error to figure out which of the eight or so existing exceptions that were already there needed me to add a port unique to JRiver.

One other thing, on my network the AirLens shows up as “ConversD Device”.

I think jvvita nailed the issue, if memory serves Airlens can’t function as a Roon Core. You can’t retire the Nuclues just yet.

Are you using tidal? If so in your tidal app can you use tidal connect to see your air lens? If it’s there that means it’s on your LAN.

Otherwise unless you moved your Roon core duty’s over to one of your macs you’re still going to need you nucleus hooked up as your core. Like others have suggested this might solve the problem.

Good luck

The AL is not a Roon Server. It is a Roon Endpoint. It’s the device a Roon Server “sees” on your network via one of the protocols that Roon streams audio. In many cases it’s RAAT (Roon Advanced Audio Transport).

Leave your Nucleus and AL running on your network. Look under: Settings - - > Audio in Roon for the AL. Once you see it, you need to “Enable” it.


Many thanks. You are of course exactly right, and much appreciated.


You nailed it for me; I should have seen this but duh. This is partly my bening dense, and partly the less-than-cogent Roon terminology.

Thank you!

Exactly right; thanks for taking the time to set me straight.

Thank you!

Thank you, your response and others have been most helpful and I appreciate it.

1 Like

I never knew that, thanks!

Yup, thanks for clearing this up. I feel sheepish …

No need for sheepishness (what a brilliant term that is) - I have long complained around here that streaming vendors and users use different terms for the same thing interchangeably.
Server, endpoint, renderer, streamer, and a whole bunch more.
And that’s before considering USB as a transport for digital audio, which just ups the confusion ante.

If it is now working, all is cool :sunglasses:



Please let us know when/how you get it sorted.

This is how we all learn and benefit from this Forum.


1 Like

Will do. I’ll post my opinion about combining the Roon Nucleus with the AirlLens, a comparison I have not see before. I’m doing this to see if galvanic isolation combined with the I2S connector makes a substantial difference in sound quality compared to the Nucleus alone with its USB connection to my MK2 DAC. It’ll take few days before I can form an opinion, especially since back problems are currently inhibiting my ability to crawl around and bend over to hook things up.