AirLens. Is there a MConnect lite pairing sequence for Qobuz?

This is my first PSA forum post. I just purchased an AirLens. My first PSA product since I owned a 6.0/Delta 100 preamp amp combo about 15 years ago.

Anyway, I found an AL on Audiogon, and it arrived yesterday. I connected it via Ethernet and powered it up. Green light on the back, and solid blue on the front. I installed the MConnect lite app, since I use Qobuz. The AL didn’t show up on the UPnP list, nor is it available on Spotify Connect.

I did reboot, restart

I am using mconnect Control HD on my iPad which handles Qobuz just fine. You might want to try it vs Player Lite.

I never got to finish my original post. I did a complete power down, restart, and reboot of everything from the modem forward. I spent about 5 hours last night trying everything I could think of.

Neither the MConnect lite app, nor Spotify Connect shows the AL. I do not have TIDAL.

Do I need a pay version of an app to make it work?


There shouldn’t be a charge for mconnect control.

You might want to check here:

The internet music portion of the app lists Deezer, vTuner, Tidal, Qobuz and Spotify.

As the Air Lens contains Conversdigital hardware as it’s core you need to use mconnect Control apps the bonus being unlike the other versions you get vTuner for internet radio which you don’t with Lite.

Thanks everyone. I’m stuck with not being able to see the AL on the MConnect app. My Audiolab 6000 streamer and Sony X800 are on the UPnP list, but not the AL.

I’m over at my buddy’s house hooking it up to his system where we will have Roon and a DirectStream DAC connected with I2s.

Just hooked it up at my buddy’s house. Downloaded MConnect lite. BAM! It just works. I’m stumped as to why it it didn’t work for me at my house.

Did you plug the Air Lens into the router in place of another streaming device? Still not sure why you seem resistant to using the correct mconnect app version.

1 Like

Not in place of an existing streamer. I just used WiFi with all my other streamers up to this point. Ran a new CAT8 cable directly from the router into the AL. With it now working on MConnect lite at another location, it had nothing to do with the hardware or the app. Either the lite or HD version will work the same. It turns out it was my own network connection error.

After mapping out my Ethernet cables, I believe it has to do with the fact that the WiFi network I use is NOT connected to the router that the AL was plugged into. If I would have used WiFi instead of the Ethernet, it would have worked just fine. My own big-ass mistake.

A little bit of cable management will go a long way.

Thank you everyone. The problem is solved.


Glad you got it sorted.