ASUS Router Issue with RoonServer on Mac Mini to DS Sr Bridge II


#1

Update: Problem Resolved by enabling Multicast Routing on the ASUS Router.

Anyone else unable to get RoonServer on Mac Mini to work with Bridge II consistently?

Setup

RoonServer running on the 2014 Mac Mini connected by Ethernet to Router ASUS RT-AC5300 also connected to DSD Sr via Ethernet Bridge II. (Ethernet cables have been tested and confirmed working to specification)

iPad Pro running Roon Remote connected via wifi to same router.

Issue

Music stops often - never get more than five tracks in a playlist without it stopping. It stops on local tracks as well as Tidal.

If I connect via optical then I can run for days without any stoppage or issue. Roon radio or a long playlist just continues indefinitely.

Definitely something relating to RoonServer, the Mac Mini and the Bridge II. File format does not matter - it just seems to lose connection to the Bridge II briefly.

Bridge II on Firmware 3.6.17. DSD Sr on Snowmass. RoonServer and Roon Remote are the latest versions.

Wifi is faster than 100MBPS and internet is consistently over 150 MBPS. Definitely no network problems with any other device. Netflix in 4D streams seamlessly and has never had an issue or dropout in the last year.


#2

Can you explain how you connect via Optical? I’m assuming you mean you connect directly to the DAC and not the Bridge. If this is the case things seem to point to the Bridge given that is the only thing removed from before.


#3

Yes optical is straight from Mac Mini to the optical input on the DS Sr.

Does anyone else use the Bridge II with a Mac Mini running RoonServer. Anyone found a way to get the Bridge II to work in this configuration?


#4

I use a Mac Mini as my Roon Server. I have a DSJr which has Bridge II. Both my Mac and Bridge II are connected via Ethernet. I haven’t had any issues with playing music. My music is on a NAS and I also use Tidal. I would speak with PS Audio support as when you remove the Bridge II you don’t have any issues.


#5

I run Roon in a similar setup (slightly beefier Mac mini with 3GHz i7), and the Bridge II doesn’t have that problem with local files. It does occasionally skip through Tidal tracks, but my internet connection isn’t the best. I also frequently run it grouped with a Devialet Phantom connected via optical to the Mac.


#6

Could you check if UPNP is enabled on your ASUS RT-AC5300?

Example here, under “Basic Config.”


#7

Yes UpnP is enabled. My settings are the same as in the link you gave.


#8

Good news. Enabling “Multicast Routing” on the ASUS RT-AC5300 has solved the issue of lost connections and dropouts.

So my Router settings are default out of the box except for Enabling Multicast Routing (IGMP Proxy) on the IPTV tab in the router LAN setup.


#9

Sweet!


#10

It’s best to disable UPNP and use port forwarding if needed. Read more about it here: https://www.howtogeek.com/122487/htg-explains-is-upnp-a-security-risk/