Bridge II firmware not updating on Directstream Sr

Hey there! I’ve just purchased a directstream DAC but am having trouble updating the firmware on its Bridge II card. The unit came to me used so I updated the device firmware from Torreys to Windom; finding that mconnect threw up a “device not supported” error when I tried to stream tidal and spotify, I thought to update the Bridge II firmware as well. The network icon lights up green and the device both recognizes that it needs an update and begins that update but that’s where I’m stuck; it’s been two hours now with the unit reading “updating” with no change on my second attempt to install the firmware, having tried power cycling everything after an hour on my first attempt. Is there anything I should be double-checking to ensure I’m all connected? The instructions for firmware updates note that they shouldn’t take more than half an hour so I’m concerned. Maybe there’s a way to load the firmware directly? Thanks so much for your help!

First try turning everything in the system off all the way back to the router. Then turn them all back on starting at the router. Then if the bridge update doesnt load within an hour or so just leave it in update mode overnight. I had similar problems when updating my DSjr’s bridge but eventually it will update sucessfully.
Hope this helps

1 Like

Like Baldy said, it’s worth trying to reboot everything in the network chain. Also, try updating the Bridge through the Mconnect app itself. Folks seem to have more luck with that. Keep us posted.

1 Like

Updating through mconnect did it, thanks jamesh! I wasn’t getting percentile progress updates through the gui when updating through the touchscreen but did through the app if that helps at all with your debug.

Would it be possible to include the information that users can force updates through mconnect on the update instructions page? As a new user I was unaware of that option; if others are also reporting increased success rates, I suspect other new users might also find this information useful.

Regardless, thanks again to both of you for your time. The Directstream sounds great!

1 Like

I forgot about the Mconnect app being able to do the update successfully. Glad you got it going updated and back to work.