Cannot Connect to DS Mk2 USB Input

Steve - It’s starting to seem like you have a H/W problem with your USB input.

Just checking, I assume you have, but did you power cycle everything?

I don’t know what the protocol with the Mac’s are but starting with the G series you cannot “hot swap” inputs or outputs and Aries streamers. You have to shut it down from the front power button and also the back one too. They are and always been quirky about changing not only outputs but DAC’s. Sometimes the easiest thing to do on an Auralic streamer is to reset it to factory settings and redo the setup as if it’s the first time and force it to see what’s on the other end of the cable. So go to the main menu on the Aries and reset it to factory and then shut everything down and start over like when you first took the G1 out of the box. If that doesn’t work you have a Mk II hardware issue.

I have a mk2 I’m borrowing from a forum member. I also use a wireworld USB out of my Aries G2. I had the USB running to my matrix with I2S out no issues with mk1. When I ran the usb direct to mk2 I couldn’t get it to play DSD 256. I went in the setup menu on the Auralic under processor setup go to resampler. Mine is set to off. Open it up and make sure your DSD settings are set to DOP. My 256 was set to native when I switched it to DOP I was able to hear DSD 256 thru the MK2. I hope this helps.


1 Like

Adding to above suggestions: how many inputs are hooked up and simultaneously running actively? Did you set the MK2 input selector to auto or manual?

Same here. Wireworld USB from Signature SE to MKII usb. no issues. Set to DoP right now. I have not tried DSD as I was told that would not work from Sonore to MKII.

1 Like

So your opinions the MK2 DAC versus the ETHOS onboard DAC appear to be what I am more curious about? Which DAC conversion solution do yo prefer?

Thanks for all the responses. Everything has been power cycled multiple times, and in reverse order. The Aries and Mk2 were powered off when I changed connections, powered Mk2 first and was then told by Aries that the selected output (which had been USB) was not available with my device. I checked all the settings, multiple times but, again, the problem is not limited to one device (I’ve tried four, so far). My microRendu is already on 2.8 OS. MacBook Pro is running Monterey, not that that should matter. I suspect Vince and dawkinsj are right that it is probably a hardware issue, or maybe a software problem (could it be a bad firmware load–I haven’t changed anything with the firmware since I got it?). When I get my second Mk2 (I’m probably well behind you, emailists), if it works I’ll have a better idea. Still waiting to hear back from PSA support. For now I’ll just stick with the Matrix and IS2.

1 Like