Cannot Connect to DS Mk2 USB Input

Since receiving my DS Mk2 3 1/2 weeks ago I have been very happy. It just blows away my Mk1. I had planned to keep my Mk1 for my second system but after a brief trial with the Mk2 in that system I bit the bullet and ordered a second Mk2 (still waiting for it).

Since I received the Mk2, I have been using the same set-up as the Mk1–an Auralic Aries G1 via USB to a Matrix XSPDIF2 to I2S1 input. Having now put in over 500 hours of burn-in time, I decided it was time to try a direct USB connection to the Mk2. The same USB cable (Wireworld) was long enough so it was an easy switch. Problem is the Aries does not recognize the Mk2 and won’t even let me select USB out. I tried the microRendu I use in my second system (and an old SonicOrbiterSE I had laying around that still works) and those streamers also do not show up as available either in Roon or LMS/Squeezelite. The light on the Mk2 is green when those components were connected via USB and volume is set to 100 but the streamers will not even attempt to play using a direct USB connection. Note I have rebooted everything multiple times after making the new connections.

I’m stumped. Any suggestions? Settings I may have missed? Anything? @tedsmith or anyone else?

1 Like

I’m pretty sure there’s no option on the MK II to help you with that USB issue. I’m sorry I can’t help with the other software and hardware you mention.


Thanks Ted. I should have mentioned I also tried a direct connection to a 2016 MacBook Pro and Audio Midi Setup also did not see the Mk2.

That’s different. I’m not familiar with the Wireworld USB cable. Is it a certified USB cable? If not you might try any old cheapo USB cable as long as it’s certified. Non-certified USB cables often work well in some USB setups and fail in others (that’s what the certification checks for.)


The Aries units all the way back to the Mini can be quirky when changing outputs. Best advice is to completely shut down the G!, the Mk II and the iPad/iPhone wait a few minutes and then boot them back up again one at a time. I would do the Mk II first and the iPad last.

Just because a friend plans to buy the Mk II and uses a G1…do you think it’s a HW compatibility issue with the G1 so that it will only play I2S with the Mk II?

No, that is the beauty of USB. If there’s a problem it’s probably in the user settings, the software or the tables software uses, etc.


With the microRendu and MacBook Pro I used a 1m Cardas Clear cable and the cable that came with my Matrix. The Wireworld is their current top-of-the-line model (I think), in 2m. With the MBP I had to use a USB-C to USB-A adapter (used the Apple adapter and, even though USB-C is not supposed to care which way the cable is plugged in, I tried it both ways). I rebooted everything in different orders but same non-result. I may have to wait for my second Mk2 to see if it’s something peculiar to my unit. I put in a support ticket and will see what they say. Thanks for the responses.

FWIW, I use a wireworld USB cable from a sonore rendu to the mkii. It works fine for me.

1 Like

Have used multiple Wireworld USB cables with no issues with any streamer DAC combo including multiple Auralic’s.

1 Like

Thanks for the input guys. I don’t think it’s the cable or the Aries. I just plugged my MacBook Pro into my Mk 1’s USB input using the Cards cable and Apple USB-C adapter and the Mk 1 (“PS Audio USB 2.0 Adapter,” or something like that was the label) showed in Audio Midi Setup and Qobuz was able to play. Not so with the Mk 2.

This may be irrelevant but I noticed that, when I connect the various devices to the USB input, I get the green connected light even though they’re not really connected. But my I2S1 light stays red even when music is playing through it. Something off there

Green on AES3, S/PDIF and TOSLink means that there’s a valid signal present on that input.
Green on USB means there’s a verified connection to a host from the Mk II.
Green on I2S means that the plug present pin is gounded (raised?) on the HDMI connector.
The problem with the I2S indicator is that non-PS Audio I2S sources often don’t hook up that wire so you often have red when you shouldn’t.


Thanks Ted. So the red indicator when using the I2S input has nothing to do with my USB problem. Oh well. Still a mystery as to why I get a green indicator with all these devices on USB when none of them actually want to communicate with the DAC–I guess you need more than a verified connection.

The green light means the USB hardware is working fine.

I suspect that many pieces of software have tables of USB devices they will deal with. The USB chip in the Mk II is relatively new and at least some software simply doesn’t recognize it and doesn’t talk to it. The thing is that USB allows devices to ask about capabilities, e.g. what sample rates do you support?.. I don’t know why some software uses tables and others use capability enquiries. There must be things you can’t get from the standard USB capabilities that some software needs. Or perhaps the Mk II is presenting some feature combinations that aren’t expected.


Interesting. Amsco15 did say that he used USB (and. a Wireworld cable) from a Sonore Rendu to the Mk 2 with no problems. I doubt the software in my microRendu is significantly different from that in the Rendu, although they are obviously not identical devices. Also, my MacBook Pro is six years old so I would not think it would use unusual protocols. I would think there are others using Macs with the Mk2 via USB but haven’t heard about similar problems coming up.

Update to Sonic Orbiter OS 2.8? You might have to buy the card from sonore or small green computer.

If my memory is correct there are other forum members using Aries G series streamers with the Mk II so you may just have a bad USB board or a software bug.

1 Like

Who do I have to tip at PS Audio to make sure my first MKII gets shipped before Steve gets his second MKII? LOL - Is there a Hoarders show for audiophiles?

Me too.

1 Like