DirectStream Senior Bridge 2 - Roon goes away


#1

frownsorry_gifWhat has become a maddening reoccurring incident is the loss of Ethernet connectivity between our DirectStream DAC SR Bridge 2 and our Small Green Computer i5 (1TB) Roon Appliance. Our crying game. We love our system but are at wits end with this situation.

looking for community support.

We listen to streaming music 80-90 of our waking hours and are home 70-80 % of most days. System stays powered on always.

Beginning to think we have two Intermittant equipment issues and not a network issue.

1st Incident description. (Intermittant)

Loss of Roon connectivity over network to Roon Remote App. Music stops playing

Loss of Ethernet indicator lights are observed

Firware updated

Occuring for 3.5 months

requires a power cycling of the Roon appliance to restore.

Resolution attempts:

reconnecting cable from switch or appliance port does not resolve issue.

new cable doesn’t resolve issue

new switch replaced does not resolve issue

switch bypass to Wi-Fi router direct connect does not resolve issue replaced with new Wi-Fi router as well

switch bypass direct connection to cable modem router does not solve issue

IP address is fixed

2nd Incident description (Intermittant)

Loss of Ethernet Bridge 2 visibility on network. Does not occur consistently with loss of Roon. Sometimes Roon is working and visible and it looses visibility to DAC Ethernet shows green but Roon cannot see Bridge 2

Started happening last two weeks

UConnect App has lost visability to Bridge 2 completely so I cannot isolate Bridge 2 testing from Roon

Recently replaced Bridge 2 (first one hard failure)

Power cycling of DirectStream to re-initialize Bridge 2 visibility of network is required.

Resolution attempts:

loss of Ethernet port indicator lights

reconnecting cable from switch or appliance port does not resolve issue.

Replacing with new Ethernet cable does not resolve

Changing input to another (IS2) and back to Ethernet does not restore

Both fixed IP and DHCP used does not resolve

New switch installed does not resolve.

Connecting direct to Cable Modem router or new Wi-Fi router does not resolve.

DS Memory Player doesn’t have any issues.

What else can I do? Loosing my mind!

Do not have a heat issue as we have had fans blowing on the units and had them setting in isolation changed locations and monitored temuratures and changed power sources.

I cannot direct connect Ethernet between Appliance and DAC as it is headless.

Appliance only has Ethernet output

I will connect MicroRendo Ethernet to USB to see if that stabilizes situation…

  • Will it keep Appliance Interface stable and will it help me isolate that my appliance has an issue?

  • Is there a Ethernet Standby or “go to sleep” occurring?

-Is there a Log File in the Appliance showing. Failure?

Also is there a log file in the DAC that we can view?

Have the ability to deploy an older Mac Mini Server to remove Roon Appliance… and may attempt this to isolate DAC/Bridge 2.

We imagine it’s possible that this is the second Bridge 2 Failure in a month…

We have also eliminated the cable modem router and isolated to a newly cabled network new hub with fixed addresses… Both incidents still occur… not the network, not our cables.


#2

Oh my - I am having the exact problem - I only got my gear on Friday - everything was working fine.

I was not home yesterday.

This morning I went to listen and am having the exact same problems - I hear about 10 secs of music and then it cuts out. Roon loses the Bridge II and then it find it again.

All other network devices are working fine.

I’m pretty stressed - I just bought all this stuff!

David


#3

The network lights on the Bridge II are green and yellow.

Solid green

Blinking yellow

Is this correct?


#4

^^Are either of you using active or passive ethernet switches in your system?

One piece of trouble shooting that worked for me with connectivity issues was to make sure the switch was powered down and “rebooted.” No guarantee this is your gremlin (or one of them), but worth a try.

Good luck to each of you.


#5

I’ve tried lots of things, including mConnect and BubbleUPnP - lots of problems - nothing works. I only set this all up on Friday.

I’m pretty sure that I have a bad Bridge II - I will call PS Audio tomorrow.


#6

Ray - have you tried other apps like mConnect or BubbleUPnP? As per my earlier post, they aren’t working either for me.


#7

Howdy Ray,

I like Dschamis’ idea of trying a different playback software to see if the same drop out issue is occurring. Also, I want to make sure that you have the latest firmware on both the DAC and the Bridge. Running Huron on the DAC and 3.3.3 on the Bridge.

-jamesh


#8

Yep Huron on DAC … 3.3.3 on Bridge II

tidal, mconnect, both same issues as well

Built a completely new network today, all new cables, no switches, no router, running Roon off of a Mac Mini.

if the DAC hickups again we’ll bypass the Bridge 2 and run USB via Ethernet converter


#9

“Doubling down” on the troubleshooting. isolation is key…

  1. The only way to isolate the suspected issues is to first simplify the network as much as possible.

By using a Windows, Linux or Mac that isn’t headless and putting an Ethernet Crossover between it and the DirectStream DAC and Bridge 2 and using static IP addresses we were able to determine that the Bridge 2 was healthy and not a problem.

  1. You don’t need to add an internet router or modem into the mix unless you are having Tidal issues with Roon. Ours wasn’t .

We then added our Roon Server Appliance to a simple basic network hub with straight through Ethernet cables and static IP’s and used the PC MAC or Linux to Monitor the connectivity or ping for failures.

We observed that the Roon Server Linux appliance would intermittently go to sleep while playing and found no issues with Bridge 2. The Ethernet LEDs the Server still were lit but the device was not pingable and the web interface was not accessible until a reboot. So one of the issues was located.

We added additional elements to the network hub one at a time and we found other impacting devices.

The Vonage Telephone adapter was doing something and would cause the Bridge 2 to shut down!!

It would also impact other devices on the network.

Also an older NAS was doing the same thing!!!

So the Bridge 2 was not an issue… these two other devices were impacting the network and Bridge 2

And yes something with the Roon Server Appliance is not right…

Removing the offending devices from the home network and running Roon on a Windows or Mac Mini with static IP’s cleaned up the issues completely.

Whew… now back to other chores and projects.


#10

Further Linux Headless Roon Server Appliance Ethernet drop out trouble shooting

fails 3-4 times every 24 hours

Power Supply fully tested good

Lan Port stays lit and flashing over loss of. communication

cannot ping or access web interface

LAN cable disconnect reconnect does not restore Power Reset only

firmware software updates have not resolved

Now cooling the case with a fan to determine if it’s heat related issue with the appliance…

Its a dark science


#11

That’s got to be pretty frustriating. Have you thought about posting this on Roon’s Small Green Computer sub-forum? I notice that SBC’s CEO Andrew Gillis spends a lot of time there. May get the help you need there.


#12

I’ve had weeks of issues with Roon. I was finally able to stabilize my setup by killing every background process in Roon. This means no library maintenance, no background analysis, no on demand analysis. These processes have nothing to do with SQ but they can make the system unstable. Schedule all Roon backups for at time that will have no impact ie, 3:00 AM. Make sure that you aren’t doing any major additions to your library by adding large amounts of ripped music. Roon does real time library monitoring and updates the database. If you’re listening to music simultaneously it can get unstable. All of these concerns affected Roon. Hopefully some are similar to your issues.