Roon no longer sees my DSJ

About 3 days ago the Bridge on my DSJ was no longer a visible device in Roon. There is no particular event that occurred that I am aware of that caused this. Spotify still sees my Bridge, which is odd. So the Bridge is still working.

A few months back my Bridge stopped working completely. Spotify and Roon could not see it. The Bridge version showed “NONE” when I cycled to the software versions on the DSJ display. I contacted PS Audio and they sent me a new Bridge to install. I did that and everything worked fine until now.

Relevant Info:

  • I’m currently running Windom.
  • I can see other devices listed in Roon such as my Chromecast and PC
  • DSJ is connected to my Wireless Router via RJ45
  • PC running Roon is connected to my Router via wifi

Things I have tried so far:

  • Reset DSJ
  • Reset Roon and PC running Roon Core
  • Unplug network cable from back of DSJ and router and plug back in.

I don’t know what I should try next. Maybe downgrade to an older software version?

Has anyone else had this issue?

Try rebooting your router

1 Like

Will give that a shot as soon as I get home.

Depending on your router, I’ve seen some (mine sometimes) that have problems passing broadcast traffic between WIFI connected devices and hardwired devices.

I did not have my bridge connected to my network on my DSJ until I installed Windom. Then I hooked it up and Roon found it and it worked great. Then the DSJ went south the same way you describe. It appears that the DSJ downloaded and updated the bridge software and that was that.
I used the online form here to contact support, and it’s been three plus weeks with no reply. I am sad about this.
As for the DSJ it isn’t important to me that the bridge works for the system it is on. I will have to call PS Audio and see if they can help me. Your description of what is happening to yours matches what is happening to mine. There is no bridge functionality and it does not matter what Ethernet cable I use or what I plug it in to. I do not believe there is anything wrong with the hardware, I think this is all software. I wish I new how to revert the bridge software.

Run a program called Advanced IP scanner and see if the Bridge shows up on the network. It’ll say something like Converse Digital. If it does, that’s good. I would the assign the bridge a static IP address, I like using MAC address to tell the router to assign the bridge’s MAC address a specific IP. This avoids any DHCP IP clashes (which could be the source of your problem). Reboot everything and see if it works. An alternate way of assigning static IPs is to do it at the DAC. You have to manually enter an IP address that’s not used on your network. Depending upon your network, a good choice is something toward the top of the IP range like Good luck. It’s usually a network issue.

1 Like

@aangen, I think the program you’re looking for to roll back bridge software is here:

It only runs on Windows machines.

My Dsj bridge is also hit or miss with both Roon and Spotify. Sometimes it shows up as an available end point for one but not the other. The volume control also has a tendency to get stuck in Roon. Running the last release of Snowmass but did upgrade to Windom at one point so might need to try downgrading the bridge as well.

In the last two months there has been a Bridge update, a Directstream update and a major Roon update so before you guys start placing blame on one company or the other try shutting everything down in your Network chain including your Router, switches, Roon server and Directstream or any other streaming device and re-boot them one at a time starting at the router and moving outward. Give each piece the time to completely re-boot before moving on to the next one. May take 15-20 minutes of your time but it will eliminate the Network as the cause and it is usually the culprit. Also you can’t just swap streaming devices in and out of a system without confusing the network as to which IP address it is sending data to. If you unplug one hardwired streaming device from and up and running network and replace it with another you have a good chance the second device won’t be recognized without a re-boot of the network.


I tried resetting the router but it did not work. No DSJ in Roon.

After a reset and reboot the DSJ says no Bridge. I’ll probably skip rebooting the router.

Unless it makes you happy, then I will.

Ran the program you suggested and ConversDigital does show up. Reset the IP to static to as you suggested. It was before I changed it. Turned off all devices and powered everything on in the following Order. Router —> DSJ —> PC —> Roon.

Still not working. Spotify works fine. Chromecast shows up in roon. This is very odd.

What’s the IP of your Roon core? Can the Core ping ok?

The router needs to power off also. When I have these issues (which are usually only after power outage or equipment swap or update) I turn everything in the system off including the Roon core or any connected computers or other devices including TV’s, AVR’s, set top boxes, etc… Then starting with the router power them back on one at a time in sequence down the chain from the router. Also include switches and access points. That usually fixes the problem.Just as an FYI, I leave everything to DHCP here.

1 Like

Manual fixed IP is ok but setting the gateway potentially important too. Dhcp takes care of that too…

The IP of my Roon core (on my PC) is I can successfully ping to my DSJ Bridge @

Yep powered off everything including the router, roon core PC, DSJ, TV, etc.

the only other thing I can think of is to make sure the subnet mask on all your devices on this 192.168.1.x network is

1 Like

I believe it already is set to that, but I will check it out when I get home.

I think the strangest thing is that Spotify sees the Bridge, Roon sees my PC (running roon core) and my Google Chromecast. Why Roon all of a suddenly can ONLY NOT see the Bridge is just really odd. I have no clue if this is a Roon issue or a DSJ issue.