DMP - Insert Disc


#1

All of a sudden my DMP will not play anymore, after inserting a cd, after say 5 seconds “insert disc” appears on the screen.
The cd has made a few turns, so I think the laser is not working because it doesn’t read the TOC. Tried a few cd’s Normal and SACD, cd’s are clean, back switch off and on, software 2.06 and 2.08, but no other behaviour. Any suggestions???

Ronald


#2

Clean the lens, either with a cleaning disc or by removing the cover, accessing the drive mechanism, and gently swabbing the lens with a clean Q-tip.
I have had a similar problem and the cleaning disc fixed it. Good luck.


#3

Thanks for your answer, that will be my first job when I come home from work this afternoon / evening.

Ronald


#4

Problem has changed, after the night. PCM plays. After inserting PCM / SACD PCM layer plays.
With SACD only the SACD layer plays. Player is very clean. Think the laser is the problem. weaker???
Software doesn’t matter and ID DMP and DSD are good.
Setup is StereoSACD, I2S cable is also good.
Shall contact my PS Audio dealer.
Or any suggestions???

Ronald


#5

Again, this is a problem I’ve had with hybrid SACDs in both the DMP and my Oppo BDP-83SE. The SACD layer is harder to detect and when the lens is dirty the unit simply doesn’t see the layer. In the case of the DMP, using a cleaning disc has fixed the problem (so far). For the Oppo, which I have owned much longer, I’ve taken the following three approaches:

  1. Use a cleaning disc when the problem first appears. Because the cleaning disc tends to only clean the center of the lens and doesn’t do a particularly through job, it only fixes minor cases of grunge build up. Eventually the amount of grunge accumulation exceeds what the cleaning disc can remove.
  2. Open the case and gently clean the lens with a q-tip or microfiber cloth. You might use a bit of isopropyl alcohol to aid in this process, but take care not to leave streaks or residue on the lens. I’ve done this at least 8 to 10 times over the lifespan of my Oppo.
  3. Eventually the diode in the laser will fail. The manufacturer may be able to replace this under warranty or for a fee, but it’s fairly easy to do yourself if you can find a replacement sled. I replaced the sled in my 83SE a few years ago for about $45 and 30 minutes of work.

I’d be very surprised if the laser in your DMP is failing. It’s likely it has simply picked up some airborne contaminants and needs a good cleaning.

Page 6 of the DAC upgrade manual describes how to open the case. I have not attempted to access the laser in my DMP, so I can’t guide you through that process. If it’s similar to the Oppo, there is a metal cover over the laser unit that you can remove. Once the laser is exposed, simply gently swab the lens with a q-tip. Also, look for and remove any other debris (my Oppo is a cat hair collector), particularly in exposed gears or on the sled rails. And, needless to say, don’t do this with the unit plugged in.

If you feel uncomfortable doing this, contact PSA and arrange to send the unit back for cleaning and a check up.


#6

Definitely contact us if you can’t resolve. We’re here to help.


#7

I have contacted my psaudio dealer, they will take care. Problem is not a dirty lens. Thanks peanut_butter for your very good answer.


#8

Please provide us with a follow-up report once you know what the issue is.


#9

Spare parts are on it’s way, I let you know as soon as the parts are in my part of the world.

Ronald


#10

DMP is back and up and running. First the transport with board was replaced. Reading SACD still a problem. Oppo software for the transport was replaced. After that SACD was working again. Don’t know all the technical details. But it’s solved.

Ronald


#11

Thank you for the update.