SACD played as PCM 24/88.2


#1

Suddenly my DMP doesn seem to want to play the SACD layer as DSD. Instead SACD plays as PCM 24/88.2. I verified that the SACD mode is set to “Stereo SACD”. The DMP is connected to my DSJr via I2S, and the DSJr likewise shows SACDs as playing PCM 24/88.2. Curious if anyone has any ideas as to the cause or a solution. Thanks!


#2

After changing the SACD “layer” between stereo DSD, multichannel DSD or CD, you need to eject the disc and reload it. I’ve also (very rarely) seen the handshaking between the DMP and the DS stop working, powering both off (with the rear switches) and then both back on has always fixed this for me.


#3

Hi Ted,

Thanks for your reply.

Unfortunately I’ve done both - ejecting/reloading, powering down both the DMP and the DSJr. Even tried altering the sequence of powering up the DMP and DSJr. Still the same result.


#4

Hopefully someone will have more suggestions, but if haven’t already you might contact PS Audio support.


#5

I can only offer one suggestion that worked once for me: connect and re-connect the HDMI cable on both ends. . . .


#6

Hi,

Thanks for your suggestion. I was hoping that somehow it would work but unfortunately that didn’t help either. I’m starting to think that i’ve developed an issue with the hardware.


#7

I was hoping that if I powered down the DMP and DSJr for a longer period of time - to have time to cool-off? - would help but that was wishful thinking. I imagine that I’ll have to send one (or both?) in to be checked. Does anyone know the proper procedure to obtain service?


#8

Call them or email them


#9

It sounds more like the DAC may have lost its ID. I believe this is a firmware problem. Give Jeremy a call and he’ll work this out for you.


#10

Hi Paul,

I shut everything down last night, expecting to trouble shoot this morning. Oddly enough, upon powering up today, SACD’s are playing at DSD 64 1-bit! Not sure why recycling the power didn’t work yesterday but I’m pleased that it’s now working. Should it happen again, should I just go ahead and contact Jeremy to check things out?

Again, thanks for your help!

Ron


#11

I’ve seen the same issue also, but only once.

Out of interest, was I2S the only connection between the player and the DAC?


#12

Yes - I’m solely using I2S connection, using the supplied cable.