Experimenting with using USB instead of Bridge II Ethernet.

Issue: Unable to send native DSF files as DSD over PCM (DoP). Just get a static sound.

DSF files must be sent to the DSD Mk 1 transcoded as PCM, and not native DSF. Roon is transcoding the DSF files as 24/352.8K which work great.

System: Roon Core running on Mac with USB connected DirectStream DAC

DAC shows green indicating bitperfect signal.

Appreciate any thoughts or is this just a limitation of the USB connection?


Must be a Roon thing, because using jRiver I can send .dsf files over USB (as DOP) to my Directstream DAC.

Same here. USB from Mac Mini to DS Sr. with JRiver. Not a single problem running DSF files to DAC. Maybe someone with Roon can chime in. After the last update there seem to be some issues.

You write: “Issue: Unable to send native DSF files as DSD over PCM (DoP)” and then “DSF files must be sent to the DSD Mk 1 transcoded as PCM, and not native DSF.” Why do you think DSF must be sent as PCM? Or do you mean DoP?

USB should not limit anything here, in fact it should offer the biggest variety of options.
There is also no known issue with Roon about this (afaik).

Can you share a screenshot of your signal path from Roon? I wonder if something like DSP/volume control is active, which would always convert DSD to PCM (not DoP).

I came across this yesterday as I downloaded the Audiophile II tracks. I stored them on my Innuos Zen. This connected to Devialet Expert by usb (normally use CAT6, but never mind).

The available settings are:

This works perfectly and sounds great, sounds better with Innuos 2.0, which is showing up Roon as being sonically inferior.

As I understand it, all DSD over PCM does it convert 1-bit DSD into a 16-bit PCM data stream and at the other end it gets converted back to DSD. So it would seem to be far less demanding than, say, 4xDSD, which is very difficult to transmit as native DSD.

Roon looks like this

One issue with Roon is that it hides duplicate versions. My Roon was only showing the 24/192 version, I had to use filters to show hidden files and I found the DSD files and played from there and Unhide.

1 Like

Did you look under the VERSIONS option? It should list all the versions of the album that are in your Roon library.

Hidden do not show up as options until you go in general settings and choose to show hidden tracks and albums.

When I set Roon to covert DSD to PCM over USB everything works great. When Roon is set for DSD over PCM (DoP) I get low volume noise.

The DSP within Roon is not enabled.

That is not correct.

The second version of the album does not show up in my album list…

You should try one of the bitperfect test tracks from the PS Audio download page and make sure you haven’t got something else funky going on. The USB receiver chip on the DS can actually mess with your levels, treating DoP as if it were PCM and doing digital volume attenuation before handing it on to the FGPA. This of course breaks DoP. The way that happens is when the computer attached to the USB sees the chip’s volume function and sets something other than 0dB attenuation. You’ll see this if you ever connect an iPhone or iPad via USB – the volume adjustment you make on screen is actually done in the USB chip in the DS. And until you set it back to full volume it stays that way.


It does not show separately, because it’s a version and therefore automatically grouped with the other album (and only the Primary version is shown).
If you “ungroup” the album (“Remove from Group” via the three dots on the right) it will be shown separately in the album or artist view.

I know how and why it does what it does. I was showing another poster that what he said was not correct……please look at the posts before responding.

Thanks Dvorak! Will test it out. Your post was very helpful.

I’m sorry if I came across as lecturing. My intend was to clarify the behaviour even further, mainly for the other poster.

That’s cool…thanks.