DSD not playing on Roon


#1

When ever I’m playing DSD 64 on roon it downsamples6x500] down samples it and PS Audio Bridge ll used to play my DSD files no problem any idea anyone ???

DS is Red Cloud Firm 2.0.7
Bridge Firm is 3.5.1


#2

Go to “Device Setup” for the DAC. Under “DSD Playback Strategy” select the “DSD over PCM v1.0 (DoP)” option. It is probably set to “Convert to PCM” right now.


#3

there no Select DSD as you can see I’m not using the USB I’m using the Bridgell!
Unknown-7|375x500


#4


#5

What are your DSP Engine settings? I have mine set to disabled and Roon streams DSF files to my DirecStream Bridge II without converting to PCM.

If you don’t want to disable the Roon DSP engine altogether there is also an option to maintain native DSD processing without converting to PCM although I have not tried this.