Firmware updates and fixes for the new Directstream MK2

Yes, shoot me a quick email. I can either email you raw files or I can send out a thumb drive once I’m back in the office.


thanks, as always

Another caveat which might help:

Initially, when I used a large-capacity USB thumb drive (256GB, FAT32) it did not work. Switching to a low-capacity drive (32GB, FAT16) worked flawlessly.

Yes, in the past PS Audio used to require a smaller capacity USB drive as at times the PS devices had trouble recognizing and reading the files.

The problem has more to do with the software being used to do the unzipping than the Apple platform itself. Though the platform is a factor too.

If you unzip on a Mac using the Archive Manager that comes built into MacOS it seems to ignore the optional Zip file extensions that are causing the issue. At least it does on one of my Macs. On that same Mac, a different utility runs into problems because of the out-of-range time stamps in the optional part of the header for one of the entries in the Zip file. I’m guessing the software on your iPad is closely related to the MacOS Archive Manager in this respect.

FWIW, I’ve been making a living writing software that works with Zip files since the early to mid ‘90s. As a result, I have tools to help me see what’s going on (without too much effort on my part) that aren’t available to most people. As it happens, the utility that I work on is one of the ones that has trouble with those time stamps on a Mac (but not on Windows). I’ll be “fixing” that in the not too distant future.

That said, I think the best immediate resolution would be for PS Audio to rebuild the Zip file from the original firmware files without including the optional extended time stamps. If they need help doing so, they can reach out to me via email. I’m happy to help, but it’s a fairly simple thing to do. Doing so would probably make for less potential confusion on the part of anyone downloading the files in the future.

Just my 2 cents


yes, I cannot “unzip” the file…using same computer and thumb drive that has successfully done a number of PS updates past few years…

If you are using a Mac, finding the Zip file in finder and right clicking on it should bring up a context menu. Select “open with” from the menu, and you should get a list of the software on your Mac that will open a Zip file. Archive Manager should be on that list — it comes with your Mac. Select it from the list.

There is either little or no visual feedback when you do this, but it should automatically unzip the files in the archive and put them in a sub folder that has the same name as the Zip file. This works fine for me using one of my Macs and the downloaded Zip file.

(I’m not in front of a Mac right now, so I’m doing this from memory. Apologies if I have the details slightly wrong, but that’s the gist.)

Even easier on a Mac where you haven’t installed another Zip utility is to simply double-click on the Zip file in finder. This opens Archive Manager which then extracts the files as long as Archive Manager is still the default for Zip files. It is the default on a brand new, out-of-the-box Mac.

1 Like

Just download these. No need to unzip.


Nice! My MkII arrived with 1.98 Antero already installed! :smiley:


after hundreds of tries, finally have 198…not sure what I did differently…thanks to all for the great help !!!


Persistence is underrated.


Yup, I tried a 8G usb stick that worked the last time, but it did not work this time. I reformat it with FAT and FAT32, but it was still not working. Finally, waymanchen showed me a separate way.

But I use PC, not Mac so it is no help to you. Now you are good to go :golfing_man:

1 Like

Einstein’s definition of insanity does not define how many times ones need to try before qualifing for the definition :slight_smile:


I have the firmware but at the end of each song I am getting a small crackle before the next song. This is with Roon.

I think I’ve got this reproduced here. I’ll probably be working on it next week (tho there’s not much left of this week.)


I got rid of it by adjusting the sync delay and cross fade time. Both were zero before. The song seems to end a bit soon but for most songs it’s ok till you issue fox. Thanks

1 Like

Over the air updates will be a godsend. Really no reason to have this much variability in 2023. I consider myself quite tech savvy and feel that other who may not be would really struggle here.

1 Like

I am not tech savvy and got it on the first try. Used Windows and a cheap thumb drive.


Good news! Mine arriving in the next 48 hours or so shoudl then as well.


I ran into a bit of a glitch with the Mk 2 tonight — this is after applying the recent firmware update, but I can’t say whether or not it’s update related.

Playing a track I’ve had for a long time (Eagles — King of Hollywood 192/24 ALAC), it started skipping around a bit. Thinking it might be the file (though it’s been played a couple of dozen times or more on my old DS), I switched to the built-in digital output on my amp and played it there without incident. Wondering if it was a one time thing, I switched back to the MK 2, and got the same skip-ish result in the same places. Other files continue to play fine through the MK 2.

This is coming from a Roon Nucleus server over a 15 ft USB cable (Cardas Clear) to the USB input on the MK 2. The same server was feeding the amp (McIntosh MA12000) through a second USB cable (unnamed brand, but also 15 feet). This arrangement never had a glitch with the old DS. I’ve only had the MK 2 for about a week, but it’s had a lot of other music run through it during that week with no issues.

Not sure what makes sense to try next, but I’m guessing I can try working around this by down sampling the file to 96/24. I’m also happy to try things that might help determine if this is a MK 2 issue if the PS Audio folks have any suggestions.

FWIW, I’ve had the file long enough that I can’t remember where I purchased it from. Sorry.

Please let me know if I can be any help, and I’ll update here if I make any further progress. Thanks.