Foobar + Optical (S/PDIF) not working... help please

First, I know I tried this a long long time ago… but I just don’t remember if I ever got it to work. Anywho, I am trying again…

Computer w/Foobar direct to DS Senior Windows 10

Foobar works fabulously via USB… plays all 2L Nordic Sound DSD files fine. No issues here. I just select the Device from Foobar “DSD : KS : PS Audio USB Audio 2.0” and it just works… passes the bit-for-bit test fine.

Issue: Hooking up a Toslink optical cable from my sound card to the DS Senior… In Foobar, I select " DS : Digital Audio (S/PDIF) (High Definition Audio Device)"… it works and I get sound to the DS Junior but it will not pass bit-for-bit tests (basic 44/16 WAV and Flac files). Wha happen?


In Properties:

  • I have volume set for 100, Disable all enhancements, Spatial Sound is OFF.
  • For Advance Tab … should I dick with Default Format? seems odd to select one when my stuff is variable formats
  • Exclusive mode both at checked.
  • Supported formats tab is weird… most all are checked.

Reason I am doing this is to break the electrical connection between devices… and see how high my TosLink cable can go. But it won’t pass bit-for-bit test with 44/16 files.

Bruce in Philly

You might want to check out this thread for more information on the capabilities of toslink.

Do you have any DSP configured in foobar2000? Double check that you aren’t sample rate converting (some of the SRCs modify bits even for a 1-1 sample rate change) Check that you don’t have track or album replay gain set.

Also, if the bit perfect test works for a little and then flakes, check the buffering settings in foobar2000.
Some TOSLink hardware/drivers do sample rate conversion no matter how they are configured in the Windows OS.
Perhaps using ASIO instead of kernel streaming might help.

Thanx Ted

No DSPs nothing that I can see. Again, the USB out is fine and it passes bit-for-bit.

One oddity, is that in the Device panel changes when I select S/PDIF… Output format greys out, and a Fading window comes up … all set to 0 ms.

Asio… ah… where do I get that driver? I use Asio4All for my music instrument and laptop… same one? Or should I get it via Hydrogen? Ah… found it on… trying it now.

Bruce in Philly

Ok, installed ASIO component in Foobar… it displays in the Devices, but not for S/PDIF… notes in Foobar components documentation denotes that my card may not support ASIO if it does not show. Odd, it is a popular card. an on-board RealTek in an Asus motherboard… I built this a few years ago.


Bruce in Philly

Thanx Ted… I need to step away for the night… She is calling…

Don’t sweat this too much… I am happy with the USB connection… just would like to cut the metal-to-metal pipe.

Bruce in Philly

Sorry I can’t help more. At least in the past some (many?) “motherboard sound cards” always sample rate converted. I don’t know about RealTek. Perhaps a search on the foobar2000 or JRiver forums might mention getting bit perfect playback on your hardware.

Thanx man…

Bruce in Philly