Foobar2000 and Bridge II


#1

Back in the day of Bridge 1 I used Foobar2000 quite a bit because it did gapless. Once Bridge 2 came along (and did gapless with all servers) I switched to other servers because Foobar did not do DSD over the Bridge. That was some time ago and I was wondering if that had changed. I installed the latest versions of everything, including the sourceforge SACD plug-in, but no dice with DSD files. Of course, I could easily have a setting wrong. If I set SACD to put out DSD I get nothing and when I set it to PCM it transcodes DSD to PCM. I get music that way but it kind of misses the point.

I’m also curious about whether the bitperfect test files are still supported. I tried them using foobar and did not see any indicator on the DS front panel. I then tried them with JRMC 22 and still saw no indicator even though JRMC has no problem playing my DSD64 files.

Any thoughts?


#2

Don’t know much about foobar but JRMC plays the bitperfect test files on my system without a problem! Bitperfectly!


#3

See here: http://www.psaudio.com/ps_how/how-to-play-dsd-files-on-foobar/. This may be out of date, not sure. I can definitely play DSD via the Bridge, although I don’t do it very often. Single-rate only, of course.


#4

Thanks. I saw that but the instructions don’t cover use with the Bridge 2. The instructions for converting to DoP are for use with the ASIO driver, for example. Do I need to install ASIO? I don’t think it is used with the Bridge.

I tried the bit perfect test files with JRMC again and this time I got the bit perfect indicators. Didn’t change any settings. Gremlins.


#5

The computer on which I have foobar2000 installed isn’t available at the moment. If I can get into it tomorrow, I will check the settings and report back.


#6

Thanks magister. No rush. I’d just like to have foobar as an option when my other servers are acting up.


#7

DSD now seems to be working in Foobar over the Bridge II. The bit perfect test still isn’t working in Foobar (but is in JRMC). Din’t change any settings that I didn’t then change back. Maybe just rebooting did it. Or damn gremlins again. Computer audio still drives me crazy sometimes. I hope the PSA streamer in development solves that.


#8

Glad it’s working. My audio computer should be available late tomorrow (if the new network switch arrives as scheduled). I’m not sure what’s going on with the bit perfect test though. I never tried it with foobar2000.


#9

I’m not really worried about the bit perfect test. If something was getting altered DSD wouldn’t be playing. And it was last time I checked.


#10
stevem2 said DSD now seems to be working in Foobar over the Bridge II. The bit perfect test still isn't working in Foobar (but is in JRMC). Din't change any settings that I didn't then change back. Maybe just rebooting did it. Or damn gremlins again. Computer audio still drives me crazy sometimes. I hope the PSA streamer in development solves that.
The DSD path bypasses some processing in foobar2000, e.g. the volume control and possibly DSP (I don't use DSP in foobar2000 so I don't know for sure.)

#11

Thanks Ted. I saw that somewhere (probably the knowledge base foobar2000 article). That left me even more puzzled as to why the bit perfect test did not seem to be working. Like I said, DSD is working now so I think I’m good. I’ll probably keep using JRMC Mac or Roon as my main server/player but wanted to have foobar2000 as an option. (I also have minimserver installed and available. Can’t have too many server options when you have a bunch of older but still perfectly serviceable computers laying around and numerous back-up drives. And a touch of audio OCD, of course. 65_gif)


#12

I might not have understood your question, but DSD may work fine even if the bit perfect test doesn’t just because the DSD path in foobar2000 may bypass the foobar2000 features that mess up the bitperfect test, e.g. ReplayGain, the volume control and/or DSP. I keep a separate playlist with the bitperfect test files in it and I use the Playlist Attributes plugin (http://www.foobar2000.org/components/view/foo_playlist_attributes) to turn off ReplayGain and all DSP when the bitperfect test is running.


#13

Thanks Ted. I think I was the one who was confused. I have replay gain and DSP both turned off. Some day when I have some time I’ll play with it some more and try to figure out what’s going on.