Gain Cell DAC and S300 power on, display works, but no sound

Bullet form to keep things shorter . . .

  • Gain Cell DAC and S300 were performing properly before being gone for 5 months.

  • Upon return, S300 would only go into protect mode

  • Cleaned speaker terminals, problem solved - green LED

  • Reinstalled but still no sound. Notably, no sound at GCDAC’s headphone port.

  • Confirmed source device operation on secondary system.

  • GCDAC Screen says “factory reset” when powered on

  • Pushing the square power button doesn’t clear the screen.

  • Stays that way until I fidget with the power button. (fidget, because the button seems to be binding in it’s mount.)

  • Power switch lamp flickers while I try to manipulate the button, and readout clears to normal operation

  • I can select inputs, change all settings, and volume knob shows value changes in the readout.

  • The remote control, with fresh batteries, will no longer command the unit.

By all appearances, I should have sound. I suspect the GCDAC because there is no output at the headphone jack. Suggestions appreciated. Has this got something to do with the binding power button on the face?

I haven’t owned either of those pieces, but since no one has replied (yet) I would ask, were they powered on/plugged in for the five months you were gone? If they were unplug them and any connections and let them sit for 24 hours. After that plug them in but don’t make any connections (interconnect/digital/speaker) and see if they boot up properly. If that doesn’t work contact PS Audio to see what they think. Good Luck!

Can you access the sgcd menu? If so I would turn your unit off and on using the power switch on the back. Don’t worry about the power button on the front (the blue one). If it’s not playing , make sure it is set to the proper input by cycling through them pushing the small black button on the front. If no luck, hold the black button until the menu appears. Short push through the options until you get to the reset menu. I haven’t done this but I think you use the volume knob to select your option and press the black button again. Hopefully you’ll be good to go.