I'm beginning to wonder if I’m not getting DSD playback

I’m beginning to wonder if I’m not getting DSD playback anymore. I have recently changed pre amp and power amps so maybe I’m still adjusting my hearing but my SACD ate not sounding quite as good. Only firmeare change has been to Windom on the DAC, but even tje transport is only reporting/recognising PCM. Any thoughts? These issues piss me off as I’m only in-country three weeks out of nine and messing atound with the system ain’t my idea of fun. I want to enjoy the music.

I assume you have the DMP transport.
If so, is stereo sacd selected in one of the sub menus?
It maybe set to red book CD.

1 Like

It looks like you’re not getting the handshake between your DMP and your DAC. You have to use I2s interlink and sometimes disconnecting the I2s interconnect and reconnecting plus rebooting the transport by turning the power off and back on by the back switch might work. Your DAC should show DSD 64 and not 88.2k, 24 bit.
I had that problem before, but my situation was more serious. I had to send my DAC back to change something in the input board that was defective. There is a considerable difference in sound quality between DSD 64 and 88.2k, 24 bit, DSD 64 is way better.

Thanks guys. Re boot or reconnecting the I2S worked. Alcohol induced dumbness didn’t lead me down that path last night. That is why I never mess with vinyl and turntable after beer or wine.


Why do you consider yourself dumb when the equipment is not doing what it should?

Never had to exchange or reconnect any connections on my system to make it work again.

Although I am typing this while my brand new Mazda 6 (4 days old) has decided not to start and I am waiting for the service to come and check the car out. I’m afraid another handshake issue and probably something really stupid that I missed. Hope to find out soon.

Thanks for the solution Way and I’m glad it worked out for Pete.

Glad to help. Actually I had this experience with the earlier firmware on the transport. Latest firmware, I have not had this issue since.

Yep flat battery, must have left and locked the car mindless.