MacOS Sierra and Directstream not working


#1

I upgraded my mac to mac os Sierra and all of my audio applications started giving errors when trying to output to the DS. Does anyone have any idea how a problem like this gets solved, does Apple need to fix it on the OS side or does PS need to update the firmware side, or?

Just used time machine to roll back and will hold off updating for now. Has anyone else had luck with updating or a similar experience?Th

Thanks

S


#2

sethmw,

Which audio apps are you referring to? Also, please provide your hardware list. thx.


#3

iMac with mac OS Sierra (reverted back to elcapitan and everything worked) audrivana, amarra, fidella, jriver, and bithq.

Jermy with support advised me to change the midi settings so I upgraded again, and here were the results:

Okay I updated to sierra and changed the MIDI settings, the good news Jriver works and Audrivana, immediately downloaded an udate and has worked.

But Amarra, Fidella, and BITHQ don’t work even with the Midi Setting set properly. It must be compatibility issue between the software, the OS, and the DS.

Please let me know if you receive any feed back or solutions to this issue, Thanks

Seth


#4

Seth,

Glad to know it’s working for you. I was going to do the upgrade but put that on hold after reading your post. I had to change my midi settings too after I inserted the LANRover to my system. It is still early for the other developers to catch up with the new OS.


#5

Update, ROON is working with bridge mode in Sierra with the DS but not over USB, however it is working with the Chord Hugo over USB (that’s a weird one), Tidal is also not working with the DS over USB and I didn’t try the Hugo, I just got frustrated and rolled back to a time machine from a day ago of El Capitan. I have emailed Amarra, Fidella, Roon Support, and Tidal, and am in a similar thread in the Roon Forums, so I will make sure to keep this thread up to date with any developments. Everyone else please do the same.

Yeah, it’s a mistake to upgrade OS’s this early especially if your only using your machine as a music server. Apple pushes it on you though, it’s hard to say no!

S


#6

Not sure if resetting Smc pram etc will help

http://osxdaily.com/2016/09/24/troubleshooting-macos-sierra-problems/


#7

The problem is not the OS its the Lan Rover ROON, Fidella, Tidal, and Amarra cannot output USB to the DS via the Lan Rover. Audriavan and Jriver seem to have no problem.

Seth


#8

see new thread, the problem is not the new OS it’s the Lan Rover. Removing the Lan Rover resolves all issuess

[Please post responses here: click. Elk]